Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
sixsigmaguy
New Contributor

Incremental Load with Update not concatenating Historical Data

Hi,

I have a problem which I cannot figure out.  I wrote a test script which successfully does an incremental load on two manually typed Excel files with about 15 rows of data each by doing the following:

Load INCREMENTAL.XLS

Save INCREMENTAL.QVD

Load HISTORICAL.XLS

Save HISTORICAL.QVD


LOAD * FROM Incremental. QVD

CONCATENATE LOAD * FROM Historical.QVD where not exists(Date)


One data set time overlaps the other so the end result is a larger data set with prior values being changed. My real script uses the same general logic but my resulting data set is only the incremental load. My actual data files is an Access export with different date ranges in the query. I would assume its an inconsistency in the date format but that doesn't appear to be the case. I have tried formatting the timestamp in the resulting export as a serial and a short date but it still doesn't work. My sample files aren't sensitive to format changes. It is not concatenating the historical QVD.


Does anyone have an idea what could cause this? Thank you in advance.



2 Replies
MVP
MVP

Re: Incremental Load with Update not concatenating Historical Data

could you post the incremental.qvd file and a small extract of the historical.qvd?

boorgura
Valued Contributor

Re: Incremental Load with Update not concatenating Historical Data

did you drop the above "LOAD & from historics.xls"?

If you did not do that then "Date" which have all the dates from historic QVD - and hence the where not exists will give 0 records.

On a side note, please use the where not exists(Date) - only if they are distinct dates - as it will pick only one record per Date.

Just to be sure, you can try this:

LOAD *, Date as test_Date from incremental.qvd;

concatenate load * from historics.qvd where not exits(test_Date, Date);

drop field test_Date;

store......