Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
prajwala
New Contributor II

Junk characters from SharePoint List

Hello all,

I am using RPC call to load data from a SharePoint List and I get junk characters for few fields when loaded into QlikView.

For Example, Department column has values always prefixed by ';#' like ";#Sales;#"

I tried PurgeChar(Department,';#') and this works fine when the column has only one value.

Sometimes there are multiple values separated with a comma. Example: Department having a value as "Sales,HR,Management" in this case my data looks as below

;#Sales;#HR;#Management;#

 

In this if I use PurgeChar am ending up with no space or commas in the field like "SalesHRManagement".

Can anybody help me with this? I am not sure about why the junk characters appear and I think these are not constant always.

1 Solution

Accepted Solutions
MVP & Luminary
MVP & Luminary

Re: Junk characters from SharePoint List

You could remove the first ;# and replace the other ;# with comma's:
Replace(Mid(Department,3),';#',',') as Departments

Or you could try using the SubField function with ;# as separator

EmployeeDepartments:
LOAD
EmployeeID,
SubField(Department, ';#') as Department
FROM
...source table... ;



talk is cheap, supply exceeds demand
1 Reply
MVP & Luminary
MVP & Luminary

Re: Junk characters from SharePoint List

You could remove the first ;# and replace the other ;# with comma's:
Replace(Mid(Department,3),';#',',') as Departments

Or you could try using the SubField function with ;# as separator

EmployeeDepartments:
LOAD
EmployeeID,
SubField(Department, ';#') as Department
FROM
...source table... ;



talk is cheap, supply exceeds demand