Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Save the Date: QlikWorld Online, June 24-25, 2020. Free global virtual event for data integration and data analytic gurus. Register Today
Highlighted
Not applicable

Loading Error

Error: Bad call to OpenFileOrURL: "\INLB157.tmp" and DefaultDir was empty !

Wonder if anyone has encountered this error before.

Happened during reload from Server;

reloading manually works ok.

Michael

Tags (1)
10 Replies
Highlighted
MVP & Luminary
MVP & Luminary

Re: Loading Error

It sounds very to an access- and/or right-issue which meant that the path to the file is invalid fron the server point of view and/or the user which runs the server has no access-rights to these folder and/or file.

- Marcus

Highlighted
Valued Contributor

Re: Loading Error

Can you use the ID which run the QV services to run this QVW. Can you run other QVWs in the server?

Highlighted
Not applicable

Re: Loading Error

It happens to my inline table. It was not a problem before. I can still reload from my local developer end. But when try to Reload from server this error happens. Wonder if this is a bug for v12.00

Highlighted
MVP & Luminary
MVP & Luminary

Re: Loading Error

Your manually load is also with qv 12? How looked these inline-statement?

- Marcus

Highlighted
Not applicable

Re: Loading Error

No, My manually load is with QV 11.20 SR12

The Inline-Statement are exactly the same.

Highlighted
MVP & Luminary
MVP & Luminary

Re: Loading Error

Maybe the best will be to move these posting to QlikBug with a few more details, like releases, script, logfiles and so on.

- Marcus

Highlighted
New Contributor II

Re: Loading Error

Hi, Does anyone have any further updates on this? any workaround? We have one user currently experiencing this issue since upgrading to QV12. Other users are fine on the same server.

Highlighted
Partner
Partner

Re: Loading Error

I have the same problem in 12:00 sr2, have someone found the cause of this issue?

//Gonza

Highlighted
Contributor

Re: Loading Error

I have almost the same very frustrating problem! I have upgraded our QlikView server from version 11 to version 12 SR 5 (12.0.20400.0) today. I create a new qvw file and create nothing but this simple script:

my_table:
LOAD * INLINE [

     ID, Value

     1, A

     2, B

];

When trying to reload in the Desktop Client on the server machine I get this error message:

Bad call to OpenFileOrURL: "\INL6A7E.tmp" and DefaultDir was empty !

If I run the QlikView desktop client on another computer the same qvw reloads fine, but not when I run it in the desktop client on the server machine. Log file for the qvw doesn't give any more information than this, it states the error mentioned and then on the next line "Execution finished." I tried moving the qvw to various locations, for example C:\ProgramData\QlikTech\Documents but no difference.

But it is only in the desktop client on the server machine that it does not work. If I move the qvw to a directory that is available from QV Access Point I can trigger reload in QVMC and it works! But it still doesn't work if I open the qvw in desktop client from that location.

The logged in user has full access to root on the available drives, otherwise that could have been the problem according to https://community.qlik.com/thread/84331#356807‌ where a similar (but not identical) issue was discussed.

So for me, a qvw with an inline table can be reloaded in QVS or in desktop client on another machine, but not in desktop client on server machine. Right now I have no idea why...