Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

chitemerere
Valued Contributor

Losing text object in App

I have an application with one big down red arrow to show a decrease in a measure on current versus the previous values and a big up green arrow to show an increase.  Within these two arrows is a text object which shows the percentage increase or decrease.  The application when opened sometimes does not show these calculated values, at times it shows.  I have attached screen shots of these two scenarios.  What could be the cause for this abnormal behaviour?

Thanking you in advance.

Regards.

Tags (1)
1 Solution

Accepted Solutions

Re: Losing text object in App

Hi,

if possible can you share your app.

If not join me on skype.

I will test that for you.

my skype ID: ashfaqhaseeb

Regards

ASHFAQ

8 Replies
Employee
Employee

Re: Losing text object in App

Hi Christopher,

Have you checked which layer you have these objects in (Properties - Layout - Layer). If they are in the same layer you might get inconsistent results. When developing an application with objects on top of each other I make sure I use the custom values so there is no risk of items being hidden.

Re: Losing text object in App

Hi,

Go to layout tab and select proper Layer.

Regards

ASHFAQ

Highlighted
alkesh_sharma
Contributor III

Re: Losing text object in App

Go to the layout tab and make sure you give custom layers to there objects. For eg: you may give 1 to green and 2 to red

chitemerere
Valued Contributor

Re: Losing text object in App

Dear all

Thank you very much for your feedback.  I have tried to effect this but once i do this to one object, changes are being affected on the whole worksheet even if i have selected a particular object.

Re: Losing text object in App

This could the case if you have linked objects.

make sure you have individual text objects not linked objects.

Regards

ASHFAQ

chitemerere
Valued Contributor

Re: Losing text object in App

Hi Ashfaq

Thank you very much for your input.  The objects are not linked.

Re: Losing text object in App

Hi,

if possible can you share your app.

If not join me on skype.

I will test that for you.

my skype ID: ashfaqhaseeb

Regards

ASHFAQ

chitemerere
Valued Contributor

Re: Losing text object in App

Hi Ashfaq

my apologies for the late response.  I did changes on the layout tab and selecting the proper layers and it is now working well