Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
qlikviewforum
Contributor II

Macro to copying the image works through batch file but fails to copy the image using autosys! Please help...

Hi

I have batch file which opens the qvw and with the help of macro in qvw it reloads the document and copy the image to the physics. This works file using batch file and windows comman prompt. But the same is not working using the autosys job scheduling tool without any error in the log file.

Any help on this is appreciated!

Thanks,

qvforum

6 Replies
Not applicable

Re: Macro to copying the image works through batch file but fails to copy the image using autosys! Please help...

Most likely it is due to security reasons. The user that you set up to run the scheduling tool must have the correct

access to the folders, databases/QVDs et.c. Try to test a step at the time to see where it fails.

1. Create a QV to load subset data from the datasource, dows it work?

2. If it works, try next step to copy the image.

Cheers


qlikviewforum
Contributor II

Re: Macro to copying the image works through batch file but fails to copy the image using autosys! Please help...

Thanks for your response!

I doubt that could be the reason. As when I am trying to reload the application manually or executing through the command prompt. It is able to copy the image to the required folder. But when we are trying to repeat the samething using the autosys it fails. As discussed earlier in the both the methods I am using the same folder only but still it fails.

Any other suggestions please?

Not applicable

Re: Macro to copying the image works through batch file but fails to copy the image using autosys! Please help...

The program "autosys job scheduling tool" is prpbably set up as running as a service.

You need to make sure that the service that is run is logging in as you or an account that

have the right credentials to relaod and save stuff to your folder.

Even though you are triggering the job manually in the tool, it is still the user tht is set up

in the service that is running the job.

Cheers

qlikviewforum
Contributor II

Re: Macro to copying the image works through batch file but fails to copy the image using autosys! Please help...

I have already tried with the user who is having right credentails but still it fails . Whatever! is there is any way to prove that this is only because of the security issue? This will help us to proceed further!

Not applicable

Re: Macro to copying the image works through batch file but fails to copy the image using autosys! Please help...

1. You need to log in to the account running the scheduler and open qlikview and

add the license and set the maco to allow system access.

2. Make a simple bat-file and schedule it in the tool. Bat-file contains something like:

COPY c:\images\myimage.jpg   c:\newfolder\myimage.jpg

Then you rule out that it is NT-security issue with folders.

PS. Do not tru to put images in c:\, c:\windows... or folder belonging to someone elses user-folders.

3. Try to do a new bat file that loads a simple Qlikview and schedule it. Bat-file contains something like:

C:\Program Files\QlikView\Qv.exe /r "c:\myqlikviews\myqlikview.qvw"

If that still doesn't work, then i can't help further

Cheers

qlikviewforum
Contributor II

Re: Macro to copying the image works through batch file but fails to copy the image using autosys! Please help...

I followed the above steps and I am able to copy the image from one location to the another. So it proves that it didn't got failed due to any security reasons.

Any help further?