Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Customers, Partners & Luminaries only: You're invited to a Data Analytics Roadmap session. Read More
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Macro wont activate on app opening

hi guys

i have a macro that change the selection color but it only active when i run it from ctrl+m

Screenshot_14.png

but i need to run it each time the app is opened

so i made a trigger that would run it "onopen"

Screenshot_15.png

but it doesn't seem to work like in the picture i tried to call it using name+() or just name

but it doesn't seem to work

any help would be appreciated

12 Replies
Highlighted
Not applicable

Highlighted

Where do you open your "app"? In QV Desktop or in an AccessPoint client?

Highlighted
Not applicable

i tried on both

Highlighted

Macros that try to manipulate the UI won't work in the Ajax Client.

Highlighted

Hi Ahmed,

Could you remove the round brackets in the trigger and try?

Capture.PNG

Highlighted
Not applicable

already tried also and nothing happens

Highlighted

Below attached file is working fine in my QlikView version 12.

Highlighted
Not applicable

Thanks Tamil i put your Msgbox code inside my Sub and it actually runs but that it the rest of the code doesn't work
maybe it's just as @Peter  said above "Macros that try to manipulate the UI won't work in the Ajax Client."


Screenshot_18.png

Highlighted
Not applicable

so is there away to work around it