Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
Not applicable

Missing zero values

Hi everyone.

I am loading data off an excel file and find that whenever the value is a zero, then it does not show in my straight table.

I checked the properties to show all values, even nulls!

I can however see the zero values in the preview table in the table structure, just not on the front end for some reason.

As an example in the load script, if I say num(if([Value] = 0, 0, [Value])) as Value, nothing is returned.

If I say num(if([Value] = 0, 111, [Value])) as Value, then 111 is returned.

Not certain as to what I am missing here.

Thank you.


Tags (1)
1 Solution

Accepted Solutions

Re: Missing zero values

Hi,

     Are you using this in chart or script?

     If you are using this in chart then make sure you have seen below property.

     Chart Properties -> Presentation -> Suppress Zero Value.

     Make sure that this property is unchecked.

Regards,

Kaushik Solanki

View solution in original post

2 Replies

Re: Missing zero values

Hi,

     Are you using this in chart or script?

     If you are using this in chart then make sure you have seen below property.

     Chart Properties -> Presentation -> Suppress Zero Value.

     Make sure that this property is unchecked.

Regards,

Kaushik Solanki

View solution in original post

Not applicable

Re: Missing zero values

Hi.

Thank you for your assistance, it worked!

Yes, it's in my straight table.

I have never noticed this option in Presentation - I was checking under Properties.

Thanks again.