Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

kamielrajaram
Contributor III

Module Security

Good day experts,

I have a document that contains a macro to genrate and save certain reports to pdf. This is done using windows task scheduler, but this job fails. When I open the document I am prompted to select module security access.

1.My server is restarted daily

2. Module security is set to system access and allow system access.

Why does this happen?

I am not sure of how to solve this.

Thank you

Kamiel

1 Solution

Accepted Solutions
kamielrajaram
Contributor III

Re: Module Security

Thank you all for the advise. Managed to resolve the issue by opening the document from Qlikview Personal Edition option to open in server. I was prompted for module security and made the required selection. When I opened the document on the server, I was not prompted for Module Security.

Thank you

Kamiel

View solution in original post

5 Replies
MVP & Luminary
MVP & Luminary

Re: Module Security

You need also settings by user --> properties --> security and your user from server-account need the proper access-rights to the file-system.

- Marcus

MVP
MVP

Re: Module Security

Hi

If your batch file opens the model using Qv.exe, you can use the /NoSecurity switch. For example, for a reload:

C:\...\Qv.exe /r /nosecurity D:/../Models/MyModel.exe

If you are using opening the document using the OCX object in a cscript, then I am not sure.

HTH

Jonathan

Logic will get you from a to b. Imagination will take you everywhere. - A Einstein
Partner
Partner

Re: Module Security

MVP & Luminary
MVP & Luminary

Re: Module Security

If you are reloading using a qv.exe command line, you must add the switch

/NoSecurity

to the command.

-Rob

kamielrajaram
Contributor III

Re: Module Security

Thank you all for the advise. Managed to resolve the issue by opening the document from Qlikview Personal Edition option to open in server. I was prompted for module security and made the required selection. When I opened the document on the server, I was not prompted for Module Security.

Thank you

Kamiel

View solution in original post