Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Problems calling functions from load script QV 12

I'm having a problem. I upgraded from qlikview 11 to qlikview 12.0.20400.0 SR5 64-bit Edition.

In qlikview 11 I was able to call a function from the load script with no problems. Now qlikview does not recognize my functions and I´m getting error messages.

Somebody had the same problem? Any suggestion?

1 Solution

Accepted Solutions
Highlighted
MVP & Luminary
MVP & Luminary

You will need to turn off bnf mode if you are using module functions in your script.  Add this as the first line of your script:

///$bnf off

-Rob

http://masterssummit.com

http://qlikviewcookbook.com

View solution in original post

4 Replies
Highlighted
MVP & Luminary
MVP & Luminary

You will need to turn off bnf mode if you are using module functions in your script.  Add this as the first line of your script:

///$bnf off

-Rob

http://masterssummit.com

http://qlikviewcookbook.com

View solution in original post

Highlighted
Partner
Partner

Great!

Now it works fine.

Thank you very much, Rob.

Highlighted
Contributor III
Contributor III

This solution does not work in 12.30 😞

Highlighted
Contributor
Contributor

It was really helpfull por I have the inverse problem. The script I developed in view 12 doesn´t work in view 11.
The error says: "Syntax error, missing/misplaced FROM"
I am uploading n files with a loop. It work in view 12 but not in view 11.
Thanks!