Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Leverage your QlikView investment to modernize BI – see how! Join Group
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

QV 9 Open URL trigger not working?

In my script I build a URL in a field called URL.

I used to use QV 8.5 and had a macro that ran on selection of the URL field, all this did was go back and open the URL.

Now we've upgraded to QV 9 and my URL macro doesn't run? I know that 9 has the ability to open URL's without a macro using the new Open URL action. I've gone into the document properties and under field event triggers I selected URL, clicked the button OnSelect Add Action(s) Added an External Open URL action and in the URL field entered =URL.

BUT this doesn't work, selections of the field just select normally and no URL is launched? I've even tried setting it to run the macro as it used to but this doesn't work either?

Can anyone please advise?

Thanks

5 Replies
Employee
Employee

QV 9 Open URL trigger not working?

On open URL is a frontend action and it is not available for backend triggers (like OnSelect). Your old macro should however still work if started through the Run Macro action.

Highlighted
Not applicable

QV 9 Open URL trigger not working?

Can you post the macro that used to work in QV8.5?

Highlighted
Not applicable

QV 9 Open URL trigger not working?

hi,

i have been trying the same approach as your's for quite sometime but it doesn't work.i don't no why.

But the following macro code works fine in QV9

sub OpenURL

if ActiveDocument.Fields("Link").getSelectedValues.Count = 1 then

ActiveDocument.GetApplication.Launch ActiveDocument.Evaluate("URL"),""

ActiveDocument.Back 'Go back so we don't do the selection

end if

end sub



pls check the attached application

thanks

Highlighted
Creator
Creator

Re: QV 9 Open URL trigger not working?

Hi all,

I'm trying to use this macro on QV 11 and it doesn't work from Web Access Point but works perfectly in development environment (desktop software). Is there any solution for this?

Best Regards,

~Sergejs

Highlighted
Not applicable

Re: QV 9 Open URL trigger not working?

Hi,

I'm also checking for same solution. Can you please help me on this if you got solution.

It is very urgent.

Greatly appreciated on your response.