Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
Partner
Partner

QV - Web File - A security problem occurred

Hi Qlik community,

I've a blocking problem with my QlikView 12.10 server.

I have a QlikView server (named "myServer") on which is also running IIS hosting a web application listening on port 444. I'm using a local SSL certificate.


Imagine an application that do this very simple stuff :

DATA:

LOAD Id FROM [https://myServer:444/GetXmlItems] (XmlSimple, Table is [ArrayOfItems/Items]);

EXIT Script;

  1. If I open this URL (https://myServer:444/GetXmlItems) in IE, the result is an XML file. Everything works fine.
  2. If I reload this application by using QV Desktop on my Workstation. Everything works fine.
  3. If I reload this code by using QV Desktop on myServer :
    • The first time I reload, the following error message occured : "Error: A security problem occurred."
    • Without exiting QV Desktop, I try again and it works well without any error message. Strange isn't it ?
    • If I quit QV Desktop and do the same test once again, same issue. The first test end with an error, the second (and the others) works well.
  4. If I reload with QMC, same issue than with QV Destkop on myServer.

I try this code :

SET ErrorMode = 0;

DATA:

LOAD Id FROM [https://myServer:444/GetXmlItems] (XmlSimple, Table is [ArrayOfItems/Items]);

--

DATA:

LOAD Id FROM [https://myServer:444/GetXmlItems] (XmlSimple, Table is [ArrayOfItems/Items]);

EXIT Script;


The reload in QMC works well. The first load crash, the second works.


I've absolutely no idea.

If you have some... please help me


Thanks in advance


1 Solution

Accepted Solutions
Partner
Partner

Re: QV - Web File - A security problem occurred

Pb Solved !

First pb : In IIS, for the concerned site, in SSL Settings, select "Ignore Client certificates".

Second pb : In IE, Internet Options, Advanced, unselect "Do not save encrypted pages on disk".

1 Reply
Partner
Partner

Re: QV - Web File - A security problem occurred

Pb Solved !

First pb : In IIS, for the concerned site, in SSL Settings, select "Ignore Client certificates".

Second pb : In IE, Internet Options, Advanced, unselect "Do not save encrypted pages on disk".