Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Save the Date: QlikWorld Online, June 24-25, 2020. Free global virtual event for data integration and data analytic gurus. Register Today
Highlighted
New Contributor

QlikView UI slowness

Hello,

I have a small model of 185 MB . I can filter on it fast when it is in developer mode. But when it is in Access Point, each step takes 20 sec.! Please advise what can be the reason and how to check it.

1 Solution

Accepted Solutions
Highlighted
MVP & Luminary
MVP & Luminary

Re: QlikView UI slowness

Beside the available resources from the server it's possible (but IMO rather unlikely whereby you could check if there are any proxy-server between your browser and the Qlik server) that there is a network-delay (if so it should be noticable with nearly all applications and not only a few).

Another more probable cause could be that there is any section access which might break some calculations. The easiest check would be just to disable it.

Furthermore take a look on the used releases from the client and the server - both should be the same.

- Marcus

View solution in original post

13 Replies
Highlighted
Partner
Partner

Re: QlikView UI slowness

Could you describe your environment(s)?

Do you have a QlikView Publisher? What's the specs (RAM/CPU) on the QV server (and on the QV publisher server)?
Plees ekskuse my Swenglish and or Norweglish spelling misstakes
New Contributor

Re: QlikView UI slowness

Hi,

please see below and attached : we have QV publisher on QV server . In the attached  I put RAM/CPU information.

 

Highlighted
Partner
Partner

Re: QlikView UI slowness

I only see one screenshot, are you running QlikView server and Publisher on
the same server?

>From my experience QlikView need at least 4 CPUs to perform optimal. With
one or two you can get in trouble. In the system requirements it written
Multi-core but multicore should be interpreted as 4+.


Plees ekskuse my Swenglish and or Norweglish spelling misstakes
Highlighted
New Contributor

Re: QlikView UI slowness

Hi, yes. We have publisher installed, but we don't use it.
Highlighted
Partner
Partner

Re: QlikView UI slowness

Have you monitored the system resources when accessing the application from accesspoint? Compare it with using the desktop client. It could give you a hint of what's happening.

 

Off topic: Why aren't you using the publisher? It has many great features/benefits even when it's installed on the same server as the QlikView Server installation. 

Plees ekskuse my Swenglish and or Norweglish spelling misstakes
Highlighted
New Contributor

Re: QlikView UI slowness

Hi,
Not sure why we are not using a publisher, I think it is a matter of license cost.
Regarding the performance. I followed up the task manager while filtering the model in AP, seems like CPU get stuck - when I click on filter they up to 17%, then they get down to 0%, but seems they are stuck like the model itself:
[cid:image001.png@01D514A2.B9118BD0]
Highlighted
Partner
Partner

Re: QlikView UI slowness

Are you using Internet Explorer and IE Plugin? If yyes then read this support document. https://support.qlik.com/articles/000070544
Plees ekskuse my Swenglish and or Norweglish spelling misstakes
Highlighted
New Contributor

Re: QlikView UI slowness

Hi,
I use Google Chrome.
Highlighted
Partner
Partner

Re: QlikView UI slowness

You got how many locgical CPUs? Four or more?
Plees ekskuse my Swenglish and or Norweglish spelling misstakes