Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
The #1 reason QlikView customers adopt Qlik Sense is a desire for a modern BI experience. Read More
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

Re : Problem While using the same codition for the function Avg and Median

Hi Friends,

In my report, i need to calculate Avg(), Min(), Max() and Median(). Without Median function, the table show the data as per the condition.

But while adding the Avg and Median function in the same chart neglect the condition present inside it and produce this garbage and null values. Garbage value for Avg () and Null value for Min(), Max(), Median().

When adding not isNull() function inside the Avg() or Median() produces correct output by eliminating.

May i know why this issue present and help me with the information you know about this.

Regards,

R.Srinivasan.

8 Replies
Highlighted
Partner
Partner

Put a sample Application so we can check and help you out on the same.

Highlighted
Not applicable

Hi Deepak,

Here i have attached the sample report created just to check for the Avg and median functions.

We are using QV v8.5.

Highlighted
Partner
Partner

hi Srinivasan,

Sorry i am not clear but can you tell which table is causing a problem.

Highlighted
Not applicable

Hi Deepak,

When you see the Chart named "Median and Average Check ", you can see the null values present for the median function and garbage values for avg function.

But the same function created in different chart i.e., one chart "Average Check"contain only the avg function, it doesn't contain the garbage values. Same for the median, look at the chart "Median Check".

Highlighted
Partner
Partner

HI , Please check my attachment i dont see any null value..!!1

Highlighted
Not applicable

Hi Deepak,

But i get null values. Here is the screen shot of the report.

Is this version problem?

What version do you use?

Highlighted
Partner
Partner

I am using QV 9 SR3....

Highlighted
MVP
MVP

I'm using 8.50.6231.5, and not seeing the bad values either. I see what Deepak sees. I have no idea what might be causing the weird values.