Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

qlikmpate0
Contributor II

Relating data not showing

I have a Qlikview document to show Requisitions, PO's and then the Accounts Payables. I'm missing some joins from the PO to AP as I do not get the relating AP information for a PO. I have added my document. Please can someone advise.

Thanks in advance

Tags (1)
13 Replies
Partner
Partner

Re: Relating data not showing

hi

the problem seems to be in the apinvdists table

it only have 29 rows in it

puttemans
Valued Contributor

Re: Relating data not showing

Hello Mina,

After checking your file, I think the issue is in the links 'Join to AP invoices D' and 'Join to PO dists I' in your APInvDists table. They show subset ratios of 0.01% and 0.05% respectively. (so basically no fit) As there is no fit, you won't see a link in your data either. This could mean that your 2 fields you're linking each time are not similar. I'd start by checking those.

Regards,

Johan

Re: Relating data not showing

check the join on

as [Join to PO Line Locs]

this does't have proper data

qlikmpate0
Contributor II

Re: Relating data not showing

Thanks but not all data showing, do i need to do the loads differently ie reorder?

qlikmpate0
Contributor II

Re: Relating data not showing

Show I load the tables differently to get the data i need?

puttemans
Valued Contributor

Re: Relating data not showing

Hello Mina,

I'd first have a look at the different variables that make up your link.

e.g. AP_Invoice_Distributions_All.PO_DISTRIBUTION_ID vs PO_Line_Locations_All.LINE_LOCATION_ID

Put theze next to each other, and compare them. Best would be to do this for a PO/AP that should be common.

This is what you defined to be the link between AP & PO, but there seems to be a very limited fit. This may be due to a format difference, even though the data are similar. In that case, you re-format one of the variables so that they match, and the link becomes much stronger. This is similar for the other link I mentioned.

Regards,

Johan

Re: Relating data not showing

its hard to tell ...can you please share the sample data or qvd so that we can help you out

qlikmpate0
Contributor II

Re: Relating data not showing

My Ap Invoice distributions is out of sync with the other qvd's. This may be the problem, I'm just testing this now.

qlikmpate0
Contributor II

Re: Relating data not showing

Hi Avinash,

Have you had a chance to have a look at the QVD's