Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Modernize Your QlikView Deployment webinar, Nov. 3rd. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Not applicable

SAP BEx Connector issue

Hi all,

I am currently using the SAP BEx connector (v6.0), but I am wondering if there are any known limitations in the number of fields (or characters) which can be retrieved? When I retrieve 49 fields it works fine, but when I am adding an additional field the load fails. (It does not matter with which fields I am doing this, I tried with several).

Any ideas what might cause this issue?

Regards,

Bjorn Miessen

1 Solution

Accepted Solutions
Highlighted
Not applicable

Qlik Support look at the matter and concluded it is a limitation in the Bex- connector:


There is a limitation in SAP that sets the maximum number of drilldown characteristics in a BEx report to 49. This means that the number of displayed characteristics can be maximum 50 but there can be additional free characteristics in the report. In the select window for the QV BEx Connector the characteristics and the free characteristics are listed together under Dimensions. Therefore it is possible to select more than 49 characteristics for the QV script and thereby cause the extraction to fail.

An alternative or workaround could be to extract a maximum of 49 dimensions (characteristics) for each extraction and store each result in different QVDs. Then JOIN and/or CONCATENATE data from the different QVDs. The key figures are not concerned with this limitation i.e. for each extraction you can extract a good number of key figures.

View solution in original post

3 Replies
Highlighted
Creator II
Creator II

Hi Bjorn,

I have been working with BEX connections as well and it offers several limitations. We have been creating some best practices guidelines in order to stream line the data load. BEX has a limitation of 2 million cells per report. However, you can create a larger query. Try to follow some steps below to improve the extraction.

1. in the connection string, increase timeout "Timeout=3600". This will hold the connection for a longer period of time. The standard time settings is '1000', or 10 minutes.

2. Remove the total rows from all characteristics. This might reduce to half the size extract.

3. Remove filters and restrictions from Default Values area and place them into Characteristics Restrictions. Filters and restrictions under Default Values are still buffering unnecessary data into the server memory,

4. If possible, ask to the BI admin, to increase the server memory for buffering.

5. All fields under the Free Characteristics are buffered as well. Remove all unnecessary dimensions.

Above a just a few hints that were very useful for me and I hope it helps.

LD

Highlighted
Not applicable

Qlik Support look at the matter and concluded it is a limitation in the Bex- connector:


There is a limitation in SAP that sets the maximum number of drilldown characteristics in a BEx report to 49. This means that the number of displayed characteristics can be maximum 50 but there can be additional free characteristics in the report. In the select window for the QV BEx Connector the characteristics and the free characteristics are listed together under Dimensions. Therefore it is possible to select more than 49 characteristics for the QV script and thereby cause the extraction to fail.

An alternative or workaround could be to extract a maximum of 49 dimensions (characteristics) for each extraction and store each result in different QVDs. Then JOIN and/or CONCATENATE data from the different QVDs. The key figures are not concerned with this limitation i.e. for each extraction you can extract a good number of key figures.

View solution in original post

Highlighted
Creator II
Creator II

Another best practice we found that worked for us for queries with several key figures with large sets of data, is to split these queries in different time frames, for example, by periods (4 months), extract all of them in parallel and concatenate them in the same QVD.

This reduced one of our extracts from 40 minutes to 9 minutes.