Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Save the Date: QlikWorld Online, June 24-25, 2020. Free global virtual event for data integration and data analytic gurus. Register Today
New Contributor III

Thousand, Million, Billion Glitch with DSE/Set Analysis?

Hello I have run into this issue and hope someone out there has a solution/workaround:

On most graphs the thousand, million, billion symbols/logic works perfectly like below:

works.png

However in this instance (below) I am getting incorrect labeling (the number is not reducing by 1,000 - nor can I force it due to number variance and drill down dropping bellow 1,000 and even to single digits):

doesntwork.png

I believe this issue can be attributed to the expression which is doing a sub calculation (dollar sign expansion) in set analysis:

expressionandproperties.png

Has anyone else run into this? And is there a workaround or solution to making the k, m, b (thousand, million, billion) work with DSE?

Thanks,

Yogi

1 Solution

Accepted Solutions
Highlighted
New Contributor III

Re: Thousand, Million, Billion Glitch with DSE/Set Analysis?

Updated to new QV and it's fixed! Thanks all

View solution in original post

3 Replies
Highlighted
MVP
MVP

Re: Thousand, Million, Billion Glitch with DSE/Set Analysis?

Can you attach sample qvw please?

Highlighted
New Contributor III

Re: Thousand, Million, Billion Glitch with DSE/Set Analysis?

Added a sample qvw as requested

Highlighted
New Contributor III

Re: Thousand, Million, Billion Glitch with DSE/Set Analysis?

Updated to new QV and it's fixed! Thanks all

View solution in original post