Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

QlikWorld 2020: Join us May 11 - 14, 2020 in Phoenix, AZ. Register early and save $400. Learn More
New Contributor

Unable to run macro from command prompt

Hi guys,

We run a Qlikview report at a client which executes some VBScript within Qlikview.
We then call this Qlikview document like this:

"C:\Program Files\QlikView\qv.exe" /l /NoSecurity "\\server\Qlikview Report.qvw"

This obviously launches the report in Qlikview, leaving the document open to allow the Macro to run.

There is then a Post Reload trigger to run a particular function.

The trouble is, the module editor is launched and does not proceed.

This has only begun happening in the last week or so, so I suspect a Windows update may be at play here, however, I am struggling to identify which one and have even tried a full re-installation of Office.

To add to the above, the module editor launching suggests a bug in my code, so I have tried a number of combinations, including stripping all of my code out an having a blank function as the only thing in the module and launch it with Post Reload, i.e.

Function Test

End Function

This also fails, suggesting to me that I may be a Windows security related issue?

Thanks in advance for any help!

4 Replies
New Contributor

Re: Unable to run macro from command prompt

Apologies - I left out some information and can't seem to find an edit post button anywhere.

Please note, these macros run absolutely perfectly when called from a button.

It is only when being called from a batch file/command prompt/post-reload function that the macro fails.

New Contributor

Re: Unable to run macro from command prompt

Turns out this is a Qlikview bug.
Happens on any version of Qlikview from November 2017 Release SR1 ( onwards.

We reverted to 12.10 SR9 and the problem resolved itself.
Will issue a bug report with Qlik.

New Contributor

Re: Unable to run macro from command prompt

I just came upon this same issue.  Any chance this bug has been addressed?  We are on 12.30.20000.0 and cannot revert to a previous version.


Any workarounds available?


Thank you


Re: Unable to run macro from command prompt

You appear to be running the initial release version, I would recommend trying things in SR3, which is the latest release in the 12.30 track to see if you can still replicate things there.  I found a few bugs in the system, oddly they stated the IR should have the fix, so I think the best thing is to test in the latest SR, which is SR3, and if you still see the issue, then I would recommend opening a support case with us, so we can look into things again to see what you may be doing differently in that case in the macro, as that is where I would have to imagine things are likely going wrong in this case.  


To help users find verified answers, please don't forget to use the "Accept as Solution" button on any posts that helped you resolve your problem or question.