Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Partner
Partner

Variable value disapears when publishing

Hi ladies and gentlemen,

I have a variable directly set in variable overview with the following value :

=GetFieldSelections(_ROLE_INCLUS_RATIO_RES13)

My issue is the following : when I reload and publish the application on the access point, the value of the variable is deleted on the published version (user document), whereas the source document still has the right value, which means the reload is not a problem.

Do you have a lead on what is happening during the publication, making the variable content disappear?

Thanks

3 Replies
Highlighted
Luminary
Luminary

Re: Variable value disapears when publishing

Hi Emmanuel,

  Got the same problem on customer, but my expressions reference only a variable like this example:

  variable2=if (variable1=0,0,variable1)

variable1 have value set on load script = 0

  at the end variable1 retain the value but variable2 gets empty.

  Did you found a solution ?

 

Regards,

Pablo

Highlighted
Luminary
Luminary

Re: Variable value disapears when publishing

Solution found.

In my case the variable had the property "include in Bookmarks" active and the distribution process was forcing the evaluation of the formula and saving the result of the expression.

I deactivated the property from the variable and problem was solved.

This article was helpful. https://qliksupport.force.com/QS_CaseWizardKnowledgeArticle?id=kA5D00000008QobKAE vVariables not sav...

Regards,

Pablo

Highlighted
Partner
Partner

Re: Variable value disapears when publishing

Hi Pablo,

thank you for your answer, and sorry for the delay. I don't remember how the problem got solved, it's been while now... I think I did nothing and it got solved "by itself" (the server team must have done something and I had had no info).