Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

juleshartley
Valued Contributor

Zoom macro works on desktop but not accesspoint

Hi All,

I have a simple zoom-to-fit macro that works fine when run on the desktop and it has been working fine on the server.

However, in the last day it seems to have stopped working on the server. I've checked that 'allow macro execution on server' and 'allow unsafe macro execution' are ticked on the QMC.

The only thing that I can remember doing of any significance is restarting the QMS, QMC and QS services

Sample macro that runs from a button is here:

Sub mcrZoom

set mysheet=ActiveDocument.ActiveSheet

set sp=mysheet.GetProperties

sp.ZoomFactor = 1.5

mysheet.SetProperties sp

End sub

Very grateful for any suggestions!

Thanks.

Tags (2)
3 Replies
fdelacal
Valued Contributor

Re: Zoom macro works on desktop but not accesspoint

SEE THIS POST, MAY BE HELPS YOU

http://community.qlik.com/message/1292#1292

REGARDS

juleshartley
Valued Contributor

Re: Zoom macro works on desktop but not accesspoint

Thanks - but I've tried that, and it doesn't seem to help.

juleshartley
Valued Contributor

Re: Zoom macro works on desktop but not accesspoint

I'm not sure what has fixed it, but I've unchecked 'enable push from server' and 'macro override security' and re-opened internet explorer and it seems to work. Not sure exactly why this should have made any difference.

Will update this thread if I learn any more details.