Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
Not applicable

"Failed to load document, You don't have access..." Popup fix/suppression using AJAX client.

Hi,

I realize similar issues have been posted several times before, but in researching all other posts I am yet to find a solution to my issue.

My server setup is:

QlikView Server version 11.20.12354.0 Enterprise Edition with 5 Document CAL's

Windows Server 2008 R2 Standard Service Pack 1 (64 bit edition)


Qlikview Server configuration:

  • First, I created a custom directory (Directory Service Connector) with a username & password. I then created a custom user for this directory. To this custom user, I then assigned 1 of my Document CAL's from the Documents > File.qvw > Document CALs tab of the file I wish to access via AJAX. I also ensured that the Authorization tab > Users with Access to this Document was set to "All users".


  • To ensure that the custom user directory works, I have the QVS set to DMS authorization (not NTFS). I then set the QVWS authentication type to "Custom User" and the Login Address to "Alternate login page (web form).


  • Now, when I access the path via a different computer I am initially met with a popup that says "Failed to load this document, you don't have access to this document", then the web form appears in my iframe and I am then able to successfully login with my username and password I created in the custom directory.

My issue is: I am using this Qlikview Document as a demonstration to clients. If clients see the "Failed to load this document" popup, they will become confused and think the demonstration is broken. How can I suppress this popup?

Document fixes I have performed:

  • Under Document properties > Opening tab > Uncheck both Initial Data reduction based on Section Access & Strict Exclusion
  • Ensure there is no section access to this document

I'd greatly appreciate any help on this issue. I've spent several days researching fixes to no avail. Let me know if I need to provide any more information.