Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Announcements
Coming your way, the Qlik Data Revolution Virtual Summit. October 27-29. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

section access profiles user admin

 

Hello,

I create a session access fir reduction. Works Well but I want also get the profiles user

How can I do that, please ?

 

 

SECTION ACCESS;


SECTION_ACCESS_USERS:
LOAD
ACCESS,
UPPER(NTNAME) AS NTNAME,
PROCESS_REDUCTION,
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

SECTION APPLICATION;

 

LINK_PROFILE_USERS:
LOAD
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES,
PROFILES_USERS_QUALIFICATION
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

 

LOAD
PROFILES_USERS_QUALIFICATION,
PROFILES_USERS,
USERNAME,
VALIDATEUR,
VALIDATEUR_RESTREINT,
QUALIFICATEUR,
GESTIONNAIRE
FROM $(vFolderQvd)PROFILES_USERS_FINALE.qvd(qvd);

 

Thanks for your help.

 

Labels (1)
1 Solution

Accepted Solutions
Highlighted
Partner
Partner

Try to run the script below in a separate application. It's your original script without the section access activated. Add a couple of list boxes, one per table. Click on the different NTNAMES fields to figure out what's happening.

//SECTION ACCESS;

SECTION_ACCESS_USERS:
LOAD
ACCESS,
UPPER(NTNAME) AS NTNAME,
PROCESS_REDUCTION,
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

//SECTION APPLICATION;

LINK_PROFILE_USERS:
LOAD
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES,
PROFILES_USERS_QUALIFICATION
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

 

LOAD
PROFILES_USERS_QUALIFICATION,
PROFILES_USERS,
USERNAME,
VALIDATEUR,
VALIDATEUR_RESTREINT,
QUALIFICATEUR,
GESTIONNAIRE
FROM $(vFolderQvd)PROFILES_USERS_FINALE.qvd(qvd);

 

Plees ekskuse my Swenglish and or Norweglish spelling misstakes

View solution in original post

2 Replies
Highlighted
Partner
Partner

When I test the login USER only the system account (admin) is granted with the configuration table not users.

Highlighted
Partner
Partner

Try to run the script below in a separate application. It's your original script without the section access activated. Add a couple of list boxes, one per table. Click on the different NTNAMES fields to figure out what's happening.

//SECTION ACCESS;

SECTION_ACCESS_USERS:
LOAD
ACCESS,
UPPER(NTNAME) AS NTNAME,
PROCESS_REDUCTION,
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

//SECTION APPLICATION;

LINK_PROFILE_USERS:
LOAD
UPPER(PROFILES_USERS_QUALIFICATION) AS LINK_PROFILES,
PROFILES_USERS_QUALIFICATION
FROM $(vFolderQvd)Securite_User_Admin.qvd(qvd);

 

LOAD
PROFILES_USERS_QUALIFICATION,
PROFILES_USERS,
USERNAME,
VALIDATEUR,
VALIDATEUR_RESTREINT,
QUALIFICATEUR,
GESTIONNAIRE
FROM $(vFolderQvd)PROFILES_USERS_FINALE.qvd(qvd);

 

Plees ekskuse my Swenglish and or Norweglish spelling misstakes

View solution in original post