Qlik Community

QlikView App Development

Discussion Board for collaboration related to QlikView App Development.

Highlighted
qvraj123
Contributor II

what is wrong with my show/hide - QV V12.3 - any suggestions pls - this is driving me nuts

Hi

I am using QV version 12.3 - trying to hide a table box with the help of the button but it is not working..

1).create the variable in variable overview window

Capture1.PNG

2.use the button - creation action - set variable  - tried with 0 and 1

Capture2.PNGCapture3.PNG

 

3).in the table box - show/conditional

Capture4.PNGCapture5.PNG

 

when i click on the button it does not hide - this is really driving me nuts - i am missing something

Text Box with value - will hide the table box when i click on the X but got stuck

X

when I click on the button i want the table box to be shown ; i am going to another text box with X as a close button so

that the table box is hidden when clicked on X - can someone suggest what i am missing here

 

thanks for your timeCapture6.PNG

 

 

1 Solution

Accepted Solutions
Partner
Partner

Re: what is wrong with my show/hide - QV V12.3 - any suggestions pls - this is driving me nuts

You only have the action to set it to 1, so it's always one and will never hide your box, since your expression on the chart will always be true.

 

Use another condition on the button, like so:

if(vShowHideDef=1,0,1)

That will change the value based on it's current state, if its 1 it'll go to 0 and the opposite is also true.

3 Replies
Partner
Partner

Re: what is wrong with my show/hide - QV V12.3 - any suggestions pls - this is driving me nuts

You only have the action to set it to 1, so it's always one and will never hide your box, since your expression on the chart will always be true.

 

Use another condition on the button, like so:

if(vShowHideDef=1,0,1)

That will change the value based on it's current state, if its 1 it'll go to 0 and the opposite is also true.

qvraj123
Contributor II

Re: what is wrong with my show/hide - QV V12.3 - any suggestions pls - this is driving me nuts

Thank you - now i figured it out...

Marcos_rv
Contributor II

Re: what is wrong with my show/hide - QV V12.3 - any suggestions pls - this is driving me nuts

try use:

$(vVARIABLE) alone:)

saludos!!!