Skip to main content

QlikView Connectivity

Discussion board for collaboration related to QlikView Connectors.

Announcements
CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
danmercer
Creator
Creator

Salesforce Connector API

Hello Everyone,

Can someone please tell me, or point me to something to read as to what changing the API could do for the SalesForceDLL.dll(64) connector?

I'm having trouble pulling data from a custom table in SalesForce and am wondering if this might be the problem.

Thanks!

7 Replies
buzzy996
Master II
Master II

I'm having trouble pulling data from a custom table in SalesForce -- are u using the same API IN QLIKVIEW whichever ur sales force application using?

danmercer
Creator
Creator
Author

Shiva,

I'm not sure what our API setting in Salesforce is.  I sent an e-mail to our admin this morning.  What's interesting or odd to me is that I changed the API and ran the extract scripts again and I didn't see any changes.

buzzy996
Master II
Master II

ya,i had a similar kind of problem earlier..pls try to use ur SF app  API whichever they were using,hope that helps.

can u try with API 21?

danmercer
Creator
Creator
Author

It's certainly a place to start looking - thanks for helping.

Changing it to 21 caused the Custom Table to not be found.

23 and 26 both found the table, but returned 0 lines.

buzzy996
Master II
Master II

okie, try with ur sf application API,that is the case.

danmercer
Creator
Creator
Author

Well - Salesforce support hasn't been much help.  They're contending that since they can access it with their dataloaders that it's a qlikview problem.  We also CANNOT access it with a microsoft tool either (I forget the name of it)

I've tried every API we have, I've tried two versions of the saleforce connectors.  The FORECASTING table is the only one that is giving us ANY issue in any manner.  API lower than 25, it says there is no table or cant connect, and anything above it finds the fields, but returns zero rows.

Can you, or anyone else, point me in a new direction?

danmercer
Creator
Creator
Author

Well - Salesforce support hasn't been much help.  They're contending that since they can access it with their dataloaders that it's a qlikview problem.  We also CANNOT access it with a microsoft tool either (I forget the name of it)

I've tried every API we have, I've tried two versions of the saleforce connectors.  The FORECASTING table is the only one that is giving us ANY issue in any manner.  API lower than 25, it says there is no table or cant connect, and anything above it finds the fields, but returns zero rows.