Qlik Community

QlikView Connectors

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

No rows for hierarchy 0FUNCT_LOC_HIER

Dear experts!

I have a question concerning the extraxt of the hierarchy 0FUNCT_LOC_HIER:

I'm using the Extractor Connector to load this data from the SAP (no BW).

Result of extracting data ist always:

     0 lines fetched

     0FUNCT_LOC_HIER << ExpandedLeaves 0 lines fetched

The log file "QvSAPExtr" contains "2016-01-20 15:22:08     Received: E1RSHND, Rows: 0, Total Rows: 0"

So I get no data for this. This is really strange because  the "Server" log contains this:

     2016-01-20 15:22:07     Requesting a new SAP Data job: 0FUNCT_LOC_HIER, Logical Sys: QVEXTRX999, ASHOST: 192.12.155.10, Id: 253

     2016-01-20 15:22:07     Hierarchy: TPLH

     2016-01-20 15:22:08     253 : Started job: REQU_QVEXTRX999_20160120152206

     2016-01-20 15:22:08     Received: 0FUNCT_LOC_HIER, Id: 253, rows: 206, Total rows: 206

     2016-01-20 15:22:11     rqState 9: Reported complete by SAP, id: 253

->so there is some Data...

I'm using the generated script:

HIERARCHY(NODEID,PARENTID,NODENAME,,NODENAME,HIERARCHY)
LOAD
NODEID,
INFOOBJECT,
NODENAME,
TLEVEL,
LINK,
PARENTID,
CHILDID,
NEXTID,
DATEFROM,
DATETO,
INTERVL;
SQL EXTRACTOR 0FUNCT_LOC_HIER
UPDMODE H  
// Hierarchy extractor
TFRMETHOD T   // tRFC transfer method
HIERARCHY TPLH
HIERLANGUAGE German
HIERTABLE E1RSHND
LOGSYS QVEXTRX999
;

Can someone help me?

Thanks!

10 Replies
Employee
Employee

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Hi Markus,

The curious value could occur because the resulting rows from SAP contains both "data" and "text". If you uncomment the part in the script that retrieves the text information, I believe the result will be 206 rows of text and 0 data rows.

Br,

Tomas

Not applicable

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Hi Thomas,

Thank you, but unfortunately for the text the same result is coming .

     2016-01-21 14:07:01     EXTRACTOR 0FUNCT_LOC_HIER#UPDMODE H#TFRMETHOD T#HIERARCHY     TPLH#HIERLANGUAGE GERMAN#HIERTABLE E1RSHFT#LOGSYS QVEXTRX999#

    2016-01-21 14:07:01     EXTRACTOR = 0FUNCT_LOC_HIER

    2016-01-21 14:07:01     UPDMODE = H

    2016-01-21 14:07:01     TFRMETHOD = T

    2016-01-21 14:07:01     HIERARCHY = TPLH

    2016-01-21 14:07:01     HIERLANGUAGE = GERMAN

    2016-01-21 14:07:01     HIERTABLE = E1RSHFT

    2016-01-21 14:07:01     LOGSYS = QVEXTRX999

    2016-01-21 14:07:01     TimeoutSAP      :14400

    2016-01-21 14:07:01     TimeoutInit     :900

    2016-01-21 14:07:01     TimeoutActivity :7200

    2016-01-21 14:07:01     TimeoutData     :3600

    2016-01-21 14:07:01     Received Hierarchy Meta Data

    2016-01-21 14:07:02     Information from server: INFOMSG : Started job: REQU_QVEXTRX999_20160121140701

    2016-01-21 14:07:02     Received: E1RSHFT, Rows: 0, Total Rows: 0

    2016-01-21 14:07:02     Disconnected

    END AT:

    2016-01-21 14:07:02

    Total run time: 00h 00m 02s

-->0 rows in QV but 206 rows in server log:

     2016-01-21 14:07:02     Received: 0FUNCT_LOC_HIER, Id: 10, rows: 206, Total rows: 206

The script for this:

LOAD
INFOOBJECT,
NODENAME,
TXTSH;
SQL EXTRACTOR 0FUNCT_LOC_HIER
UPDMODE H  
// Hierarchy extractor
TFRMETHOD T   // tRFC transfer method
HIERARCHY TPLH
HIERLANGUAGE German
HIERTABLE E1RSHFT
LOGSYS QVEXTRA131
;

...Any other ideas...? Thanks.

tobivogt
New Contributor III

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Hi,

maybe some points you might check:

Has the DataSource been activated in SBIW?

Do you get some records with ExtractorChecker RSA3?

Maybe the language should be D instead of german?

Check /QTQVC/STATUS table, maybe a former request has status S and should be deleted.

If there has been some version changes, will you get the same results for a new logical system?

I hope there might be some usefull hints to fix your problem.

Have you already extracted any other data via extractor connector from this system?

Regards,

Tobias

Employee
Employee

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Hi Markus,

What connector version are you running?


At this point I suggest you contact the Qlik Support with a link to this thread.

Thanks,

Tomas

Not applicable

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Hi Tomas

We are running V 5.80 SR4, 2211 vs. SAP Basis 7.31.

Markus

Not applicable

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Hi Tobias,

Thanks for your hints.

All points you mentioned have been checked...:

-The DataSource is active

-RSA3 delivers records

-Language setting change doesn't help (i tried also D, English, DE, E, EN)

-Former requests have been aborted

-A test with another log. system leads to the same result

-The extractor works fine with other sources and even with other hierachies

Regards,

Markus

tobivogt
New Contributor III

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Hi Markus,

thanks for sharing your results.

Some more questions:

Have you already checked the SAP GateWay?

Maybe there is a recinfo or secinfo record missing (TA: SMGW)

Gateway-Sicherheitsdateien secinfo und reginfo - Sicherheitseinstellungen beim Gateway - SAP Library

I had some issues with this several times.

The SAP Network service is the corresponding one from your Connector Version?

Just an idea - I don't know which effect this might have.

Regards,

Tobias

=====

EDIT: Sorry, I didn't see the last post. So via Extractor Connector you can extract other sources from the same system and other hierarchies from the same object?

Not applicable

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Hi Tobias,

Yes:

-The Extractor Connector fetch data from other sources (e. g. 0FUNCT_LOC_ATTR) from the same system

-The Extractor Connector fetch data from other hierarchies (e. g. 0WBS_ELEMT_WBSH_HIER) from the same system

We have problems only with 0FUNCT_LOC_HIER.

Regards,

Markus

Employee
Employee

Re: No rows for hierarchy 0FUNCT_LOC_HIER

Please download the latest version of the connectors from the Qlik Website. If the issue persists, please reach out to the Qlik Support with a link to this thread (as mentioned above )

(Edit: Have you tried calling the hierarchy using the idoc method?)

Best regards,

Tomas

Community Browser