Qlik Community

QlikView Connectors

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

QTQVCEXTR1 no extractors found for logical system

Hi experts

We are using QlikView 11.2.

SAP Connector 6.3 has been installed.

All connector types to BW on HANA work fine, except the one for SAP Extractor.

We have done the setting as described in the document, here for SAP BW, not for ERP:

https://help.qlik.com/en-US/connectors/Subsystems/SAP_Connectors_Help/Content/6.1/Configuration/SAP-...

Activating an extractor in BW /n/QTQVC/ACTIVATE generates the message below:

qkli1.PNG

In QlikView connecting with SAP BW and the Logical system QTQVCEXTR1 we don't get any extractors.

qkli2.PNG

At which place did we miss any customzing in BW?

SM59 for QTQVCEXTR1 and testing the Connection results in a failure:

qkli3.PNG

SAP ECC/ERP:

https://help.qlik.com/en-US/connectors/Subsystems/SAP_Connectors_Help/Content/6.1/Configuration/SAP-...

Any ideas?

Thanks

Thomas

3 Replies
Not applicable

Re: QTQVCEXTR1 no extractors found for logical system

partly resolved:

I have deleted the logical system QTQVCEXTR1 and its corresponding RFC connection in SM59.

Thereafter recreation of this system.

Now the extractors are given in Qlik, but the data loading / execute script ends with an error:

FAILED  Error:
LOCATION    CPIC (TCP/IP) on local host with Unicode
ERROR       hostname 'sapbwas04' unknown
TIME        Tue Nov 22 13:59:52 2016
RELEASE     720
COMPONENT   NI (network interface)
VERSION     40
RC          -2
MODULE      nixxhl.cpp
LINE        183
DETAIL      NiHLGetNodeAddr: hostname cached as unknown
COUNTER     1

SQL EXTRACTOR 80EPM_DS01
TFRMETHOD T  
UPDMODE F  

LOGSYS QTQVCEXTR1

Employee
Employee

Re: QTQVCEXTR1 no extractors found for logical system

Hi Thomas,

Are you using release 6.3.1 or 6.3.2?

The 'Test connection' in transaction SM59 is not going to give a positive result if no extraction is taking place at the time. So if that was the case the error is an expected outcome.

At the bottom of the screen in transaction SM59, Gateway Host and Gateway service is displayed. Gateway Host and Gateway service are used when the Extractor connector registers the connection to SAP (before it can receive data). The entries are created when the Logical system is created or modified in transaction /n/QTQVC/EXTRACTOR_ADM. Please check if your entries are correct.

Read more about this under the headline 'Modify' in the online help:

Setting up Qlik Extractor administration ‒ Qlik Connectors

Best regards,

Hakan

Not applicable

Re: QTQVCEXTR1 no extractors found for logical system

Hi Thomas

Hope you have already solved your issue.

Just for information if someone will be facing same issue, it could be resolved by adding records to hosts file.

197.X.X.X     sapbwas04


Regards,

Medet


Community Browser