Qlik Community

QlikView Connectors

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
rrsrini2907
Contributor

QV SAP connector failed to test connection

Dear All,

We were trying to connect to SAP using SAP (7.31) Connector 5.80 SR4. We have successfully imported the transport files and created a user with QTQVCACCESS.

The user is able to query in the SAP logon.

But when we try to establish the connection between ReloadSAPDD.QVW after providing the details we get "Failed to test connection". When we check in the log, we get below message:

Creation of function /QTQVC/CHECK_RELEASE returned after 00:00:01

Progress SAP Transport information: version: ; date: 00000000; time: 000000; SAP basis: 731;

Error Missing transport number. Cannot verify version.

Progress Connection Failed


Could you please help us?


Regards,

Srini.

8 Replies
berndshexe
New Contributor III

Re: QV SAP connector failed to test connection

Hi,

we have the same problem.

Do you have a solution?

Regards,

Petra

Not applicable

Re: QV SAP connector failed to test connection

Hi, This error is when you have applied the wrong transports for the SAP BASIS version you are on:
From the manual:
4.1.2.2 SAP BASIS System 6.10 and 6.20
For these systems, the following transports must be installed in the SAP system:
 E6DK900616 (data extraction)
 E6DK900612 (user profile)
Note: For BASIS versions 6.10 and 6.20 version 5.70 of the SAP connector must be used for the Extractor and BAPI connector
4.1.2.3 SAP BASIS System 6.40 - 71x
For these systems, the following transports must be installed in the SAP system:
 E6DK900611 (data extraction)
 E6DK900612 (user profile)
4.1.2.4 SAP BASIS System 7.20 – 7.3x
For these systems, the following transports must be installed in the SAP system:
 E66K900035 (data extraction)
 E66K900036 (user profile)
The transports must be installed in the above order. The first is cross-client, whereas the second is client-specific and has to be installed on all clients where it is to be used.
berndshexe
New Contributor III

Re: QV SAP connector failed to test connection

Thanks for Your reply :-)

we have installed the correct transports, but in the wrong order :-(

darkhorse
Valued Contributor

Re: QV SAP connector failed to test connection

So does it work after correcting the order?

BR

Serhan

berndshexe
New Contributor III

Re: QV SAP connector failed to test connection

Yes, thanks :-)

rrsrini2907
Contributor

Re: QV SAP connector failed to test connection

Dear All,

My problem was solved after installing QV SAP Connector 5.80 SR3.

And in the SAP Server the port 3300 was blocked, Once we turn it on, everything worked perfectly.

Thanks,

Srini.

ralph_graham
New Contributor III

Re: QV SAP connector failed to test connection

Sorry for bumping an old post but does anyone know where to find Transport E6DK900611? It doesn't appear in the C:\Program Files\Common Files\QlikTech\Custom Data\QvSAPConnector\ Folder and is not online either.

Thanks,

Ralph

richbyard
New Contributor III

Re: QV SAP connector failed to test connection

Following on from this comment, an easy thing to miss in the documentation is the port which the SAP connector needs for communication. This may or may not be 3300 depending on your system number.  This can be found in the latest online reference manual here.

Capture.JPG

Cheers

Richard

Community Browser