Qlik Community

QlikView Connectors

Not applicable

Qlikview SAP Connectivity Problem

I am facing problems with respect to Qlikview’s connectivity with SAP. Please find the environment details below:

Hardware Details:

OS        :   Windows Server 2008 R2 sp1

RAM    :   8 GB

Disks    :   C:\ 50 GB, D:\ 100GB.

SAP Details:

SAP Version:           SAP ECC 6.0

Basis:                      Release 701 Patch Level 3

Qlikview Details:

Qlikview version: 11 SR1

QlikView version number :  11.0.11282.0

Qlikview SAP Connector version: 5.5 SR3 (file ver. - 5.5.8698.0)

SAP Transports file used: 640-700.zip (5.5 SR3)

I have installed the SAP Connector as well as transports successfully (‘select * from t000’ statement is fetching records in SAP with the creates QTQVACCESS user). Moreover, when I test the SAP connection inside Qlikview it confirms that the test connection has succeeded.

However, when I try executing the script builder it throws an error saying “Custom Read Failed”. I also tried using select statements on SAP tables – MAKT, t000 etc. but  getting the same error.

I also tried using different versions of SAP connectors:

•  5.6, 10755 SR2,

•  5.6, 10640 - Initial Release

•  5.5, SR2 but to no avail.

I also checked on the dll version and it is same as the SAP connector version.

6 Replies
MVP
MVP

Qlikview SAP Connectivity Problem

Hi,

Is there any chance that you need to check the "Force 32 bit" or uncheck it if it's already marked?

Miguel

MVP
MVP

Qlikview SAP Connectivity Problem

Hi,

Sorry, I meant in the Script Editor window, just to make sure it's using the corresponding architecture.

Miguel

Not applicable

Re: Qlikview SAP Connectivity Problem

Hi Miguel,

In my case, I have kept the "Force 32 bit" unchecked, while connecting to the SAP system

in the script editor window.

suniljain
Honored Contributor

Re: Qlikview SAP Connectivity Problem

its not issue with 32 bit.

MVP
MVP

Re: Qlikview SAP Connectivity Problem

Hi,

Try increasing the value of the "TimeOutFetch" paramenter in the connection string that is created when you select the button "Connect" in the Script Editor. If I remember correctly, by default it's set to 1200. Set it to 1800 or 2400 and let us know.

Check the SAP Connector logfile and paste it here should the above does not work.

Hope that helps.

Miguel

Not applicable

Re: Qlikview SAP Connectivity Problem

Hi,

I have increased the value of "TimeOutFetch" parameter to 2400.

Still,the error persists.

Community Browser