Qlik Community

QlikView Connectors

Not applicable

SAP Extractor Connector: Where clause doesn't work

Hi everyone,

i'm trying to add a where clause into sap extraction but it is not working.

[ZBI_NEW_ZTPRC_VP]:

LOAD

[AKTNR_TVK] as [AKTNR_TVK.Номер акции (YMMDD)],

[AUFNR_TVP] as [AUFNR_TVP.Ссылочный номер заказа],

[BISMT_TVP] as [BISMT_TVP.Номер материала внешнего магазина],

(... other fields)

;

SQL EXTRACTOR ZBI_NEW_ZTPRC_VP

TFRMETHOD T   // tRFC transfer method

UPDMODE F   // full extractor

//UPDMODE C   // initial extraction, to be followed by delta extractions

//UPDMODE D   // delta extraction

//INITRNR <NR>  // Resend extraction

//IDOC <NR>  // Resend single IDoc

EXTRLANGUAGE E

LOGSYS QTQVCEXTR1

WHERE

AUFNR_TVP I EQ 098341769064

;

Please take into account additional comments:

1) I tried it with and without single quotes, any variants doesn't work either.

2) The field AUFNR_TVP in SAP extractor is marked for selection.

3) When I try to test extractor in SAP ERP using RSA3 and with applying filter by field AUFNR_TVP - it works.

4) The SAP extractor is based on view.

Please let me know if you have any solution regarding this problem.

3 Replies
Employee
Employee

Re: SAP Extractor Connector: Where clause doesn't work

Hi Ivan,

Which Connector version do you have?

Can you attach the connector log file (QvSAPExtr_...txt) from:

C:\ProgramData\QlikTech\Custom Data\QvSAPConnector\Log

Thanks,

Tomas

Not applicable

Re: SAP Extractor Connector: Where clause doesn't work

Hi Tomas,

thank you for your reply. I've just checked.

The cause of this problem was in stucked JOB.

After I removed this Job in /QTQVC/STATUS table the problem was resolved.

Employee
Employee

Re: SAP Extractor Connector: Where clause doesn't work

Hi Ivan,

Please upgrade to the latest version of the Qlik Extractor Connector for SAP.

The issue with WHERE clause (e.g. WHERE VKORG I LT "1001") is fixed in version 6.00 IR.

Thanks,

Tomas

Community Browser