Qlik Community

QlikView Connectors

Not applicable

SAP Extractor Connector - iDoc issue with WHERE clause

I am currently facing an issue with the sap extractor connector and iDocs. The issue is that the connector does not forward the WHERE clause into the segment 3 of the iDoc. This means the selections in SAP are not performed. The issue appears in all load cases (full load, initial load, delta load). We tested inside SAP with BW load and there it works well. The Extractor Version is 5.8.

Are there any known issues? Anyone faced similar problems.

3 Replies
Employee
Employee

Re: SAP Extractor Connector - iDoc issue with WHERE clause

Hi Raimund,

This sounds like an issue that was fixed in a later version of the Qlik SAP Extractor Connector. Can you please attach a log file (from the Service log) with the issue just to verify?

(Log folder is: C:\ProgramData\QlikTech\Custom Data\QvSAPConnector\Log)

Thanks,

Tomas

Not applicable

Re: SAP Extractor Connector - iDoc issue with WHERE clause

Enclosed the log. The Where clause is listed there but the returned results are not filtered. The iDoc in SAP misses the segment 3 where the Where clause should be stated.

Log Example for Initial Load (Mode C).:

2015-08-19 15:33:00     Connector: C:\Program Files\Common Files\QlikTech\Custom Data\QvSAPConnector\QvSAPEXTRConnector.dll Ver: 5.80 SR3, Build: 2108

2015-08-19 15:33:00     Using Server Host: 193.78.8.118 , Port: 8680

2015-08-19 15:33:00     Connected to SAP (ASHOST): 192.168.41.40

2015-08-19 15:33:00     Making new SAP Request

2015-08-19 15:33:00     EXTRACTOR YMM_PURCHASE_HEADER_TEXTS#TFRMETHOD I#UPDMODE C#EXTRLANGUAGE E#LOGSYS QTQVCEXTR1#WHERE#EKORG I EQ 3000

2015-08-19 15:33:00     EXTRACTOR = YMM_PURCHASE_HEADER_TEXTS

2015-08-19 15:33:00     TFRMETHOD = I

2015-08-19 15:33:00     UPDMODE = C

2015-08-19 15:33:00     EXTRLANGUAGE = E

2015-08-19 15:33:00     LOGSYS = QTQVCEXTR1

2015-08-19 15:33:00     TimeoutSAP      :14400

2015-08-19 15:33:00     TimeoutInit     :900

2015-08-19 15:33:00     TimeoutActivity :7200

2015-08-19 15:33:00     TimeoutData     :3600

2015-08-19 15:33:09     Information from server: INFOMSG : Started job: REQU_QTQVCEXTR1_20150819153301

2015-08-19 15:33:12     Received Meta Data, No of Fields: 8

2015-08-19 15:51:05     Received: E2RSSH, Rows: 30491, Total Rows: 30491

2015-08-19 15:51:05     Information from server: INFOMSG : Received Item No. : 0000000010887627

2015-08-19 16:00:41     Received: E2RSSH, Rows: 30509, Total Rows: 61000

2015-08-19 16:00:41     Information from server: INFOMSG : Received Item No. : 0000000010887629

2015-08-19 16:06:23     Received: E2RSSH, Rows: 19671, Total Rows: 80671

2015-08-19 16:06:23     Information from server: INFOMSG : Received Item No. : 0000000010887631

2015-08-19 16:06:35     JOB STATUS: FINISHED, Total Rows: 80671, Name: YMM_PURCHASE_HEADER_TEXTS

2015-08-19 16:06:38     Disconnected

END AT:

2015-08-19 16:06:38

Total run time: 00h 33m 38s

Employee
Employee

Re: SAP Extractor Connector - iDoc issue with WHERE clause

Hi,

There should be a '#' at the end of the string in your log: "#WHERE#EKORG I EQ 3000" should be "#WHERE#EKORG I EQ 3000#". Is that a copy/paste error?

If it is a copy/paste error, the log doesn't reveal the problem and I strongly recommend that you download the latest version of the Qlik SAP Connectors and try using that one. If the problem persists, please let us know.

Thanks,

Tomas

Community Browser