Qlik Community

QlikView Connectors

Employee
Employee

Re: SAP Fetch aborted due to incorrect number of rows

Hi Marco,

It should help to increase a certain export/import buffer size, rsdb/obj/buffersize, that can be viewed in transaction RZ11 (insert the param name in the text box and press display). Default value is 4096; in our internal dev systems it is 32768 and that works well for us.

(Please refer to SAP documentation on how to change this value).

 

SAP Documentation about rsdb/obj/buffersize:

Parameter description :

This parameter sets the size of the import /export buffer (KB).
The buffer is used for data storage in the shared memory and is
accessed using the ABAP commands EXPORT TO/IMPORT FROM SHARED BUFFER
and DELETE FROM SHARED BUFFER. The commands only affect the local
system. Buffers on external application servers are not
changed. If the buffer is full, old buffer objects are kicked out
when new objects are exported to the buffer.

 

Best regards,
Tomas

markoantonio1
New Contributor II

Re: SAP Fetch aborted due to incorrect number of rows

Hola Tómas

gracias por la respuesta.

en nuestro sistema SAP el valor actual es de 16384. respecto a ello, tengo una consulta. El cambio afectará a otros sistemas que se conectan a SAP o solo a Qlikview?

 

Saludos

Marco Antonio

Employee
Employee

Re: SAP Fetch aborted due to incorrect number of rows

Hi,

Yes, I believe it would affect all applications that use the export/import buffer as it's a SAP system property.

(Please check this brief article from Qlik Support: https://support.qlik.com/articles/000043379)

/Tomas

Employee
Employee

Re: SAP Fetch aborted due to incorrect number of rows

Hi Marco,

Some more information regarding the Export/Import buffer parameters:

Check the SAP note 702728 - Profile parameters for export/import buffer instances.

NOTE: when the parameters have been changed, restart the SAP system to activate the new values.

The following parameters are important:

rsdb/obj/buffersize
Syntax for correct size: PHYS_MEMSIZE * 1024 * 0,01.
For example, if the server has 35 Gb of memory, the correct value should be 358400.

rsdb/obj/max_objects
Syntax for correct size: rsdb/obj/buffersize / 4.
Correct value based on rsdb/obj/buffersize of 358400 = 89600.

rsdb/obj/large_object_size
Default: 8192. Because this default value has proven to be too small, it has been changed as follows in kernel patches:
- As of kernel Release 7.40 PL 68, 7.41 PL 35, and 7.42 PL 3, the default has been increased to 250000.

The parameter values can be checked in transaction RZ11 or in transaction ST02.

Regards,
Håkan

markoantonio1
New Contributor II

Re: SAP Fetch aborted due to incorrect number of rows

Hola Tomas!

Hemos aplicado el cambio recomendado y desde hace unos dias ya no se presenta en problema en la recarga. seguiremos monitoreando para que todo vaya bien.

gracias por el apoyo.

 

Saludos

Marco Antonio