Qlik Community

QlikView Connectors

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
jocampbell
New Contributor II

Salesforce connector - Login failed premature end of file

Hello everyone,

Since around 9am this morning, I've been getting the below error message on the server when trying to connect to Salesforce using the Salesforce connector. Everything works perfectly on my own desktop, it's just an issue on the server. I've tried testing the connection in a new Qlikview document and every now and then (about 1 out of 15 tries) it will connect successfully however it fails the majority of the time.

Has anyone experienced this issue before? Nothing has changed on the server as far as I can see in the way of updates etc and it was working fine prior to 9am. I've reinstalled the connector but that didn't fix it.

2014-01-30 10:01:16 Progress Connected to SalesForce with C:\Program Files\Common Files\QlikTech\Custom Data\SalesForceDLL.dll version 11, 00, 10009, 0 (DLL Protocol version: 2)

2014-01-30 10:01:16 Progress EndPointUrl=https://www.salesforce.com/services/Soap/u/21.0

2014-01-30 10:01:16 Error Connection failed

2014-01-30 10:01:16 Error Premature end of file.

2014-01-30 10:01:16 Progress Disconnecting

Thanks in advance :-)

1 Solution

Accepted Solutions
Not applicable

Re: Salesforce connector - Login failed premature end of file

Salesforce appears to have resolved the issue with the NA7 instance, with their latest Spring release update.

We're waiting for an explanation regarding the root cause.

15 Replies
tanaka_carter
New Contributor II

Re: Salesforce connector - Login failed premature end of file

I am seeing the same issue.  It works when run manually, but fails when run through Publisher on the server.  And the fails only start around 8:30 to 9 am on the average.  Just like you, nothing has changed but have been experiencing this issue on and off for a few weeks.

srchilukoori
Valued Contributor

Re: Salesforce connector - Login failed premature end of file

Hi,

We are facing the same issue. All the reloads on the desktop and publisher are failing. Any work arounds for this ?

SC

srchilukoori
Valued Contributor

Re: Salesforce connector - Login failed premature end of file

The problem seems to be fixed by itself, at least for now.

jocampbell
New Contributor II

Re: Salesforce connector - Login failed premature end of file

It fixed itself for me too... I haven't experienced any issues since about 24 hours after my original post. We deduced that there must have been an issue at the Salesforce end. I'd give it 24 hours before you panic! :-)

Not applicable

Re: Salesforce connector - Login failed premature end of file

Hello,

We've been experiencing this exact same issue intermittently for the past few weeks. If anyone has any feedback please let us know, this is what we've determined.

The connector has been working for the past 2 years and nothing has changed on our end. Our network engineer has determined that QlikView is sending packets to SalesForce and they're receiving them.

We have Hourly Reloads on our SalesForce Connector. The connector works from 4pm - 4am PST and always works on the weekends.

This issue is specific to our Production SalesForce Instance ( NA7 ), and the connector always works on the SalesForce SandBox Instance.

We've been talking with SalesForce Support for the past 2 weeks and I've opened a support ticket up with QlikView.

I wonder if this issue is specific to NA7 instance. What SalesForce instance does your connector go to and have you guys noticed issues with specific time periods?

Thank you,

Ben

tanaka_carter
New Contributor II

Re: Salesforce connector - Login failed premature end of file

We are on NA7 as well and still having the issue.  We were on QV 11.0 when it would only work between the hours of 7PM to 7AM EST.  We upgraded to 11.2 over the weekend, hoping that would help with the issue, and now the Extract constantly fails.....no more intermittent success.

Ben, what QV version are you on?

Not applicable

Re: Salesforce connector - Login failed premature end of file

Hi Tanaka,

We've been on QV 11SR2, Build: 11.0.11414.0 for about a year.

A Qlik Engineer responded today:

" It seems like it is something on SalesForce’s end. I’m in the process of locating the proper SalesForce connector resource here on our end to see if they have seen this type of issue before and I’ll let you know what I find out here on my end. "

Please keep us updated if you notice anything new Tanaka, I will also keep this thread updated. I hope that Qlik and SalesForce can work together to fix this issue.

Regards,

Ben

Not applicable

Re: Salesforce connector - Login failed premature end of file

I am facing this issue today...

tanaka_carter
New Contributor II

Re: Salesforce connector - Login failed premature end of file

I am still experiencing these issues as well.  I have cases open with both SalesForce and Qlik.....and both are saying it has been escalated to R&D.  If you are having this issue, please call support on both ends and report the issue ASAP.  I think the more people they have calling in and looking for a fix, the quicker we may get an answer.

Community Browser