Qlik Community

QlikView Connectors

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

sparur
Valued Contributor II

some problems with QV SAP Connector 5.4 SR1

Hello, friends.

I have some strange problems with the latest version of SAP Connector. Do you have something like this?

After update to the latest version my reload job is failed often, but not always.

I did some investigations and I understand that problem with getting data. My query became to return different number of rows, i.e. sometimes 'select' query return 0 rows (but I know that in the SAP table rows are exists) and sometimes return all rows (as I want).

Somebody has any ideas? why one query sometimes returns different data ?

20 Replies
suniljain
Honored Contributor

some problems with QV SAP Connector 5.4 SR1

Dear Friend,

With Update of latest version of SAP Coonector. You also have to update the file which is pasted in SAP Environment. otherwise New version does not work properly.

Because every version have different file set . so you have to paste the related file in SAP Environment.

Regards,

sunil Jain

sparur
Valued Contributor II

some problems with QV SAP Connector 5.4 SR1

Which files you mean? Do you speak about 2 SAP transports? If you mean it, I added these transports in our SAP BW system

sparur
Valued Contributor II

some problems with QV SAP Connector 5.4 SR1

the main problem, that SAP connector works differently and it very strange. I can't understand why my query can fetch 0 rows and after 5 minutes can get all rows from one table.

suniljain
Honored Contributor

some problems with QV SAP Connector 5.4 SR1

Dear Friend

Pls check with SAP Transaction code ST22 . wheter it shows any reason for that extraction or not. if yea, it have details for this error.

Regards,

Sunil

sparur
Valued Contributor II

some problems with QV SAP Connector 5.4 SR1

no, today we have no rows in ST22

sparur
Valued Contributor II

some problems with QV SAP Connector 5.4 SR1

and our job is finished successfully. so we can't find any error on SAP BW side. but our job return 0 rows and it's not normal, because in SAP BW we have more and more rows

sparur
Valued Contributor II

some problems with QV SAP Connector 5.4 SR1

and when I reload my extraction from BW after 10 minutes (for example) I can get right data with all my rows...

How can I understand such behaviour?

suniljain
Honored Contributor

some problems with QV SAP Connector 5.4 SR1

Dear Friend ,

SAP BW also works on ACID Property of RDBMS. That is Automacity, Consistency, Durability and Isolation.

When you are extracting data from SAP BW and at the same time if any communication running betbeen R/3 and B/W . At that time it gives you 0 records.

Or If at the same time insertion or updation is running on it gives you 0 records.

Regards,

Sunil Jain

sparur
Valued Contributor II

some problems with QV SAP Connector 5.4 SR1

no, my extraction (qvw reload) is running after cube refreshing on SAP BW side. and we have timeout 30 min between these 2 events

Community Browser