Qlik Community

QlikView Creating Analytics

Discussion Board for collaboration related to Creating Analytics for QlikView.

Not applicable

Problem in deployment of document with Set Analysis

num(count({<CONTAINERS.RCMSRECORD={1},CONTAINERS.OEMTYPE,CONTAINERS.VOYAGE,EVENT_LOG.EVENTDESCRIPTION,CONTAINERS.LINE_ID=>} CONTAINERS.TOTAL), 0)

this is my set analysis expression its working fine when i open qvd in Qlikview Dashbord but after deployment on server it is displaying incorrect results?

1 Solution

Accepted Solutions
Not applicable

Re: Problem in deployment of document with Set Analysis

Found the solution server was changing the format of fields that i was loading which was creating problem in set analysis comparison.

Thanks for reply Stefan.

2 Replies
MVP
MVP

Re: Problem in deployment of document with Set Analysis

That's not much information, what do you expect to see and what do you see?

Are you using same versions of QV locally (I assume that's what you mean with QV Dashboard?) and on server?

What are you trying to achieve with the set analysis? I read this as:

count CONTAINERS.TOTAL using a default selection set with modifications: RCMSRECORD set to 1 and disregard selections in OEMTYPE,VOYAGE,EVENTDESCRIPTION, LINE_ID.

I also think your format specifier for the num() function (i.,e. second argument to num) is missing single quotes indicating a format string. I  believe it should be '0' if you want to show a single digit. You could also give it a try by removing the num() function completely.

Regards,

Stefan

Not applicable

Re: Problem in deployment of document with Set Analysis

Found the solution server was changing the format of fields that i was loading which was creating problem in set analysis comparison.

Thanks for reply Stefan.

Community Browser