Qlik Community

QlikView Creating Analytics

Discussion Board for collaboration related to Creating Analytics for QlikView.

klaus_feldam
Contributor II

Problem with QV10 sum formula (works in QV8 and QV9)

Greetings fellow QlikCommunity members.
We have a set of call recording reports we are running based on data from our telephone system.

Following an otherwise successful QV10 SR2 upgrade this weekend, the result of the following formula has changed in QV10:
(SUM ([Answered Active Time])/Sum ([Number of Answered Calls])/24/60/60)

With this formula, we are simply calculating the average talk time for an agent based on the 'Answered Active Time' and the 'Number of Answered Calls'. The calculation works as intended in QV8 and QV9, but doubles the Average Talk Time in QV10. See below extract for the difference in the calculation. The formula for the ATT columns are the same.

See attached QVW. User-ID: ADMIN / Password: ADMIN.

Any assistance would be highly appreciated.
Answ   Active TimeAnsw CallsATT (post QV10) Incorrect calculationATT (QV8 / QV9) Correct calculation
-359607:39-
82102:4401:22
386112:5206:26
98103:1601:38
985132:5016:25
970132:2016:10
-118:12-
-105:42-
151105:0202:31
125104:1002:05
-105:50-
77102:3401:17
116103:5201:56
-109:20-
73201:1300:36
196203:1601:38
-204:06-
-211:41-
-107:32-
163105:2602:43
-106:38-
356111:5205:56
417113:5406:57
113301:1500:38
115301:1700:38
270303:0001:30
85400:4200:21
91400:4600:23
438403:3901:49
832406:5603:28
781308:4104:20
204302:1601:08
474305:1602:38
384112:4806:24

Best regards,
Klaus Feldam
Tags (3)
12 Replies
danielrozental
Honored Contributor II

Problem with QV10 sum formula (works in QV8 and QV9)

Klaus, perhaps you could post a reduced qvw for us to take a look?

Has the App been reloaded with QV10 or just opened with it?

Not applicable

Re: Problem with QV10 sum formula (works in QV8 and QV9)

Hi

Is it possible for you to upload the doc?

Arun

klaus_feldam
Contributor II

Problem with QV10 sum formula (works in QV8 and QV9)

Daniel,

Thanks for your response. The file has been uploaded.
The change in the calculation happened AFTER the first reload.

Klaus

klaus_feldam
Contributor II

Problem with QV10 sum formula (works in QV8 and QV9)

Arun,

Thanks for your response. The file has been uploaded.

Best regards,
Klaus Feldam

danielrozental
Honored Contributor II

Problem with QV10 sum formula (works in QV8 and QV9)

it asks for a userid...

If the problem happens after a reload then it's probably in the script. You should try to track down where exactly your results get duplicated.

klaus_feldam
Contributor II

Problem with QV10 sum formula (works in QV8 and QV9)

Daniel,

The reload script and formulas have not changed since the QV10 migration. The data is exactly the same (and not duplicated), but the outcome of the particular Average Talk Time calculation is different between QV8/QV9 and QV10. In QV10, the calculation doubles the result from e.g. 2m26s to 5m52s and 1m12s to 2m24s.

Not applicable

Re: Problem with QV10 sum formula (works in QV8 and QV9)

Hi Klaus,

Which sheet should I look at? Agent Summary?

klaus_feldam
Contributor II

Problem with QV10 sum formula (works in QV8 and QV9)

The column is call ATT and can be found on the Main tab in the 'Number of Calls with Time Cycle' and 'Number of Calls by Hour' tables. In both tables the ATT values are doubled.

Example:

HourAnsweredAbandonedTotal Calls%Avg Wait timeATTShould have been
8131513696.32%00:4408:2404:12
9380138199.74%00:3807:5003:55
10477247999.58%00:3607:5203:56
11499650598.81%00:4407:2003:40
12424442899.07%00:3807:3703:49
13462146399.78%00:3807:4703:54
14458946798.07%00:4207:3203:46
15352836097.78%00:4807:4703:54
16320432498.77%00:4507:5203:56
176816998.55%00:2706:2403:12
181721989.47%01:1406:2103:10
19808100.00%00:2205:4802:54
Total3,596433,63998.82%00:4107:3903:49
danielrozental
Honored Contributor II

Problem with QV10 sum formula (works in QV8 and QV9)

Klaus, regardless of no changes having been done to the script, it is possible a function or something else having changed from one version to another (seen that before).

You should try to figure where exactly the problem is in the script.

Community Browser