Qlik Community

QlikView Creating Analytics

Discussion Board for collaboration related to Creating Analytics for QlikView.

Highlighted
christhng1
New Contributor

QlikView -> Published QlikView Formula Error?

Hi all,
Some background:
I have done a local version of my dashboard on QlikView (licensed). Had it published into QlikView Server.
In local, dashboard was working fine - formulas, graphs all good.
In server, dashboard was working fine - all except for 1 formula which gave a ' - '.
The formula behind the output for a number is: =count(DISTINCT[Reference Number])
Anyone have experience with this? And know why? Formula problem? Upload errors?
I have tried to delete the box and re-create the formula box again.. to no avail - same error.
If anyone has any experience/workarounds please let me know! Much appreciated
4 Replies
mwoolf
Honored Contributor II

Re: QlikView -> Published QlikView Formula Error?

Have you looked at the Reference Number field to see if there is any data?

kkkumar82
Valued Contributor III

Re: QlikView -> Published QlikView Formula Error?

I guess reference number field is different in Ur local and published copy,Chech the validity of the column

christhng1
New Contributor

Re: QlikView -> Published QlikView Formula Error?

Thanks for the replies.

Data field is there.

Another formula =count([Reference Number]) is working fine on the sheet. This one is represented in Total # of Responses.

Just that when distinct is added to the mix.. it somehow disappears. And outputs a '-'

mwoolf
Honored Contributor II

Re: QlikView -> Published QlikView Formula Error?

Can you post a sample qvw that shows the problem?