Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

bme
New Contributor III

AJAX send to excel / export displays at text

We just recently upgraded to QV11 SR2 and swiched to the AJAX client from the IE pulgin. We're having a problem with the "send to excel" / "export" functionality. When a data set is large enough that it has to be sent as a csv (over the Excel 65K limit) that file is opened as text by Chrome and Firefox rather than being saved as a file. It seems to work fine in IE8 and IE9 using compatibility mode. It looks like the MIME content type being sent back with the file is "text/plain". I would have expected to see "text/CSV" or even the content disposition to be attachment. Is there any way to modifiy these headers to be more explicit or some other work around?

Tags (2)
Labels (1)
6 Replies
phaneendra_kunc
Valued Contributor III

Re: AJAX send to excel / export displays at text

Does anyone have solution for this? i have the same problem not sure how to fix this or force the browser to open up in text/excel/csv.

mwoolf
Honored Contributor II

Re: AJAX send to excel / export displays at text

When I do Send to Excel in Chrome, it adds the file to my downloads and I have to click the downloaded file to open in Excel.

bme
New Contributor III

Re: AJAX send to excel / export displays at text

The particular issue I posted this about was accepted as a bug by QlikTech and was fixed in QV 11.2. I just tested in my environment and confirmed that it is now working appropriately.

phaneendra_kunc
Valued Contributor III

Re: AJAX send to excel / export displays at text

is it true even if you try to export more than 65536 rows?

bme
New Contributor III

Re: AJAX send to excel / export displays at text

Yes, I tested it with about 90k rows yesterday evening. We're currently on build 11.20.11922.0

phaneendra_kunc
Valued Contributor III

Re: AJAX send to excel / export displays at text

Thanks so much Ben. currently we are on 11 sr2. we are planing to migrate to 11.2 sr5 in next month. i guess that will solve the problem.

thanks again.

Community Browser