Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements
QlikView Fans! We’d love to hear from you.
Share your QlikView feedback with the product team… Click here to participate in our 5-minute survey.
Rules, plus terms and conditions, can be found here.
Not applicable

Activating the QV Server License

I have a question about issuing our QlikView Small Business Edition Server license.

When I try to activate the license in QMC under System>Licenses>Qlikview Server, I got "Failed to retrieve CAL configuration from QlikView Server" error.

I validated that;

  • The service account is part of local Admin/QlikView Administrators group and the account is added into that group and the info is reflected to OS.
  • The server does have a static IP

Are there any other things that I'm missing?
That would be great if you can help me.
Kind regards,

19 Replies

Re: Activating the QV Server License

  • Does the machine on which you installed the QlikView services have access to the internet?
  • Is this machine allowed to talk https to the Qlik LEF servers in Sweden?

If not, you can ask your partner for a LEF (License Enabler File). That's a text file containing the same response you would get if your server could connect to the LEF servers. For activation using a LEF, you don't need an internet connection.

Best,

Peter

Not applicable

Re: Activating the QV Server License

Hello Peter,

Thanks for your reply. Machine has access to the internet. But I think LEF servers need to make inbound connections to the QV server right?

If that's the issue, do you know how can I get the IP or CIDR block of the servers, so that we can whitelist it?

Thanks,

Re: Activating the QV Server License

No they don't need to make an inbound connection. It's just an information exchange à la question-reply.

If you need to whitelist these servers, here are their addresses:

lef1.qliktech.com

lef2.qliktech.com

Not applicable

Re: Activating the QV Server License

pcammaert‌ thanks for your reply again! I also got the LEF file from our partner. And when I fill all the info and try to activate I get "Failed to retrieve settings from Qlikview Server" error.

Screenshot_9.png

Is it related to inbound/outbound traffic?

Re: Activating the QV Server License

Seems more like a message from the QMC/QMS. The QMS needs to get in touch with the QVS after the restart, but it seems that the QVS is down (orange bar in the background of the QMC).

Are you sure you are entering licensing information for a QlikView SBE server?

Can you check the QVS logs for a reason why the QVS is not reponsing or even going down?

Not applicable

Re: Activating the QV Server License

Yes, I'm sure I'm entering the SBE server license information.

How can I check QVS logs?

But I the reason QVS is down is that it's because I couldn't activate the license? Below is the explanation for orange bar saying 3 services are down.

Screenshot_10.png

Re: Activating the QV Server License

The screenshot shows that QVS is just waiting to be licensed. It's not down. The DSC and QVWS however cannot be reached. They're probably running as well, but the QMS cannot talk to them (either because they're not reachable, or because the account that the QMS or the others are using isn't allowed to talk to them).

In the services control panel, check which services have a status "Running".

Logs can be found by navigating to C:\ProgramData\QlikTech. Every service has its own folder with settings, logs and other stuff. You can start by checking the QMS log file, maybe after setting the log level to High or Debug.

Not applicable

Re: Activating the QV Server License

Yes you're right, all the services are actually running under the services control panel.

I made sure that we open all the traffic to the server when trying the activation but it gives the same error.

And when I check the QMS logs I saw that it says No config file:

20170503T110053.529+0200InformationAttempting to start frontend web server...
20170503T110053.537+0200InformationStarting QMS web server on port 4780
20170503T110053.541+0200InformationQMS web server started successfully
20170503T110053.545+0200InformationInitialization complete, entering main loop...
20170503T110053.747+0200InformationService host started.
20170503T110054.849+0200InformationDistributionGroupConfig: No config file C:\ProgramData\QlikTech\ManagementService\DistributionGroups\DistributionGroupDefinition.xml. Clearing settings.
20170503T110313.575+0200ErrorSystem.Exception: Failed to retrieve CAL configuration from QlikView Server ||    at QMSBackendCore.Service.ServiceImpl.<>c__DisplayClass111_0.<GetCALConfiguration>b__0() ||    at SolutionGlobal.Collections.ThreadSafeCache`2.CacheItem`1.GetObject() ||    at SolutionGlobal.Collections.ThreadSafeCache`2.Get(TKey key, Func`1 createObjectFunc) ||    at QMSBackendCore.Service.ServiceImpl.GetCALConfiguration(Guid qvsID, CALConfigurationScope scope)
20170503T110457.352+0200ErrorSystem.Exception: Failed to retrieve settings from QlikView Server. ||    at QMSBackendCore.Service.ServiceImpl.<>c__DisplayClass94_3.<GetQVSSettings>b__4() ||    at SolutionGlobal.Collections.ThreadSafeCache`2.CacheItem`1.GetObject() ||    at SolutionGlobal.Collections.ThreadSafeCache`2.Get(TKey key, Func`1 createObjectFunc) ||    at QMSBackendCore.Service.ServiceImpl.GetQVSSettings(Guid qvsID, QVSSettingsScope scope)

Can that be the problem?

stabben23
Honored Contributor

Re: Activating the QV Server License

Hi,

just to be sure here, this License is not used on another server?

Community Browser