Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

maxim_senin
Contributor III

Add Bookmark web dialog issue - no OK button

Hi,

Did someone see such an issue - Add Bookmark web dialog does not work, it does not have OK button and its Cancel button is inactive (please see screenshot below). It was working normally from the day one, but stopped at some moment. Restarting of QV services and rebooting of the HW server do not help. The server version is 11.2 SR10, release 12748.

If I remember correctly some time ago (two or three years ago) there were some troubles with bookmarks in web mode, but they were successfully fixed. It's just sad to not have bookmarks, if you have some ideas, please share.

Thanking you in advance.

Best regards,

Maxim

P.S. We have verified all .shared files by QVS.exe utility as prescribed by release notes for SR10 - no issues found. So I just shrug shoulders...

Labels (1)
1 Solution

Accepted Solutions
Not applicable

Re: Add Bookmark web dialog issue - no OK button

Check C:\Program Files\QlikView\Server\QlikViewClients\QlikViewAjax\htc\QvAjaxProperties.js

Line 18: if (!IS_TOUCHENABLED) {

is not correct

Changing this line to:

Line 18: if (!Qva.userAgentDetector.get("touchEnabled")) {

Fixes this issue.

In my case this issue aroused after upgrade of QVS. Possibly .js hasn't been rewritten.

8 Replies
maxim_senin
Contributor III

Re: Add Bookmark web dialog issue - no OK button

Really no one faced with this?

danieloberbilli
Valued Contributor II

Re: Add Bookmark web dialog issue - no OK button

Maybe due to a web browser update? Did you try it with another browser or even downgrade the current browser version for testing

maxim_senin
Contributor III

Re: Add Bookmark web dialog issue - no OK button

Hi Danial,

None of browsers was updated. Moreover if I connect to other QV server (with the same release) from the same computer there is no such issue, Add bookmark dialog works well.

So the problem is deffinitely on QV server side (either QVS or QVWS).

Best regards,

Maxim

Not applicable

Re: Add Bookmark web dialog issue - no OK button

Hi,

Just ran into the same problem with Chrome. However, with IE it works even in "Full browser client".

Chrome has been working earlier, not sure if this is broken due to some update on that side.

Not applicable

Re: Add Bookmark web dialog issue - no OK button

Actually, I can verify as well that it works on another server. With same Chrome, one server works, one doesn't. Same QV-version on both.

maxim_senin
Contributor III

Re: Add Bookmark web dialog issue - no OK button

Hi,

Very intresting. The server I wrote about still does not show OK in the dialog if I try any browser on PC but it works when I browse from smartphone .

Best regards,

Maxim

Not applicable

Re: Add Bookmark web dialog issue - no OK button

Check C:\Program Files\QlikView\Server\QlikViewClients\QlikViewAjax\htc\QvAjaxProperties.js

Line 18: if (!IS_TOUCHENABLED) {

is not correct

Changing this line to:

Line 18: if (!Qva.userAgentDetector.get("touchEnabled")) {

Fixes this issue.

In my case this issue aroused after upgrade of QVS. Possibly .js hasn't been rewritten.

maxim_senin
Contributor III

Re: Add Bookmark web dialog issue - no OK button

Hi Peter,

Thank you very much!

In my case the QvAjaxProperties.js was up-to-date, but the QvAjax.js was not updated after upgrade and object userAgentDetector was not defined.

I suppose it's worth to install new releases from scratch, i.e. not on top of existing installation next time.

Best regards,

Maxim

Community Browser