Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Ajax application won't export to excel

We have an ajax page that has four tables on it. When I try to export any of the table to excel, the popup window pops up like it should, but instead of prompting for "would you like to open or save the file", the page comes up with the "unable to view the webpage" error. the URL of the popup reads "http://qlikview/qvprint/*a bunch of letters".xls. I've also tried to export to a .csv and it fails as well. Does anyone know why this is occuring. It works on some machines but not on others and I'm not sure what setting would be doing this (IE setting, QV setting, security, firewall, etc). thanks.

18 Replies
Not applicable

Ajax application won't export to excel

I'm having a very similar issue. Our issue is with the Internet Explorer browser exporting reports as excel in AJAX. It works fine with the IE Plug-in in Internet Explorer, with Firefox in AJAX, and Crome in AJAX, but not with Internet Explorer in AJAX. We aren't getting the error that you are, which might have something to do with you have the "Web Folders" tab set up on your QVS Console. When we were getting an error, when we tried downloading the file, we changed our URL to https in the "Web Folders" URL box on the QVS Management console so it ran over the secure port. That fixed the error message, but didn't fix the fact that the file wasn't downloading...

I have a ticket into the support team at QlikTech. They have forwarded my request on to the second level of support. I'll be sure to provide an update if they get a fix for me.

rob

Not applicable

Ajax application won't export to excel

Thanks alot. I've tried everything I can think of. We tried changing all the IE security settings, the versions of excel, upgrading IE and nothing works. Hopefully they can figure something out.

philip_doyne
Contributor II

Ajax application won't export to excel

Hi All,

Experiencing exactly the same issue with QVS 9.0 SR2 (released on 30Oct). Symptoms exactly as described above but the same things happens for both Print Export and Send to Excel. In my case I only care about the AJAX client - no info about others. I have 9.00 SR1 installed locally on my PC and it works fine on that so it must be something to do with some security setting. I have Windows Server 2008 on the server. It does not seem to be browser - in IE6 I get the standard windows "The page cannot be displayed" in IE7 I get a blank page. I would expect the Send to Excel to bring up the Open/Save dialog and the Print to put the output in HTML in the web page. It seems odd that it s trying to display the XLS in a web page. Any QlikTechers on line to comment. Also have a call in to support.

Philip

Not applicable

Ajax application won't export to excel

Same here. I also have a ticket open. Please everyone keep us posted. I get more answers from teh Forum them Support.


Good Luck,

Moe

p.s. I will keep you all posted.

Not applicable

Ajax application won't export to excel

I actually got mine working here. I don't know if all of your systems are the same way, but here's what I had to do:

Ours is a sharepoint portal that links back to QV. I set up a virtual directory in IIS on our sharepoint server that links back to the printing folder through the server management console. I believe ours is something like "c:\inetpub\wwwroot\Qvprint" on our QV server. I'm assuming if you're not running through a portal you can set up a virtual directory through IIS on the actual QV server that points back to the printing folder just the same. I also changed the URL in the web folder section to be a full URL. I believe the default is just "http://QLIKVIEW/QvPrint. I changed that to http://qlikview.(whateveryoursis).com/QvPrint path. You should be able to see the full path after the domain in the ASP net section of your IIS and it's listed in virutal path. Now I also had to change the security on the QV print directory in IIS to allow anonymous access to let people go through. I had the anonymous access set to our sharepoint admin username/password and that corrected the issue. If you're not going through another box I don't know if you need anonymous or not. If your webpage authenticates back to the server as a specific username you might have to set that username as the anonymous access. Hope this helps everyone else...feel free to post if you have any questions. i'm running 8.5 here so I don't know how this translates to other versions.

philip_doyne
Contributor II

Ajax application won't export to excel

Thanks for that - a partial solution for me - I did have Basic Authentication set on the QVPrint virtual folder and after changing it to Anonymous only the Print and Export functions worked but not the Send to Excel Open/Save.

Not applicable

Ajax application won't export to excel

Hi,

Any solution related to IE "send to Excel" issue? BR, Abu

Not applicable

Ajax application won't export to excel

My previous post solved the issue from the ajax client here. We've run into a few other minor things on clients machines that could potentially be a client issue instead of a qlikivew issue from an ajax page:

1. Popup blocker cancelling the page since it pops up in a new window

2. Firewall stops the excel page from opening correctly. This is caused by the way ours is set up. The sharepoint page gets through most firewalls just fine and we have in Iframe that goes to the QV page. When ti send it to excel it tries to open a new domain/SSL cert and some firewalls block that from happening.

3. Every once and a while there's a security setting in IE that breaks it. I just reset everything to default in the IE security/advanced settings.

That's about all I know at this point - since we got it up and running on our side I haven't really looked at it too much though. Thanks

Not applicable

Ajax application won't export to excel

I think Your issue may be down to the 2008 server, I have a qvw with Some FileOpen functionality on a macro and it wont run on the server as it cant find a suitable Fileopen Dialog control on the server OS.

Mabe this is a similar issue somehow. Have you got a test box running an older Server OS ?

ColinR

Community Browser