Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

fernandotoledo
Valued Contributor

Ajax client: Localhost works, in other machines gives no licence error...

Hi everybody,

I have a QlikView Enterprise Server v.9SR3 installed in a 2003 Windows Server 32bits. I´m using QlikView Security and QlikView webserver.

It works fine all over the network with plugin and desktop clients (openning in server...).

The problem is that the ajax client, wich works fine in the server through http://localhost/qlikview, don´t work when accessed by other machines. It gives a "no licence available" error.

We don´t have a domain here and I´ve tried all configurations in the QVS Management Console.

Any suggestion?

Best regards,

Fernando [Smiley Indifferent]

2 Replies
smoon63
Contributor

Ajax client: Localhost works, in other machines gives no licence error...

Fernando,

Are you using Machine Name licenses? If so, that is your problem. The AJAX client doesn't capture the source machine information and therefore cannot validate the user who is trying to connect. The result is the infamous "no license" message. We use the IE Plugin exclusively because of this, as well as the greater security it offers.

Scott Moon

vgutkovsky
Honored Contributor II

Ajax client: Localhost works, in other machines gives no licence error...

I would also check QEMC --> System --> Web Servers --> AJAX tab, and make sure all settings are proper there.

Regards,

Community Browser