Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

gustavgager
Contributor II

Ajax client hangs, IE and open in server works.

Hi.

I have a strange issue with out qlikview server. Whenever you use the full browser client, haft the App is shown, but not everything. I have several tables and none of theese show up and the cursor is just a spinning circle (you know istead of the hourglass). This seems to be the case with several of our applications but some of the smaller ones are still working.

If i run the exact same application in IE plugin, eveyhing works fine. The same goes for open in server. I have tested on several machines and several dffrent apps on several diffrent browsers. I have also tried running it from the browser locally on the server and the issue is exactly the same everywhere.

A few weeks ago i upgraded to 11.20 SR12 and eveything has been fine for a few weeks.

yetsreday the password for the service account expired so i reset the password and entered the password into the services. Averything worked fine util this morning when i found the server beeing "off duty". It happend to be another server trying to use the same license. So i removed the QV license on both servers and added the license for this machine again (same license as befor) and it started fine. But after that, i got this problem. During troubleshooting of the "off duty" problem i restarted the services several times and i also did a repair of the QV Server installation.

I have also tried restarting all services several times, and i also retsrated the entire machine (Hyper-V VM running Windows server 2008 R2). I have checked the QV logs and webserver logs and i cannot find anyting. Any assistance would be appritiated.

Labels (2)
6 Replies
Employee
Employee

Re: Ajax client hangs, IE and open in server works.

HI,

You can use the QVSDetector to see all servers and license on your network. It is part of the Powertools

Bill.

gustavgager
Contributor II

Re: Ajax client hangs, IE and open in server works.

I have already solved that issue. This issue arised afterwards.

gustavgager
Contributor II

Re: Ajax client hangs, IE and open in server works.

Update:
I have now found out that the problem is with container objects. It stips loading as soon as it tries to display container objects. if i rmeove all container objectson the first sheet, eveything is fine untill i change sheet (and try to view another container object).

Anyone had this ssue befor?

MVP
MVP

Re: Ajax client hangs, IE and open in server works.

Was the application developed on a version of desktop more recent than the server? For example desktop is 11.2 and server is 11.0.

Containers have changed between those versions, but if your plugin is also 11.2, it would possibly work, but the Ajax client would not.

gustavgager
Contributor II

Re: Ajax client hangs, IE and open in server works.

I cannot say for sure. Some of the applications ware probably created using older versions, but have been updated continously using QV 11.20.

All this worked fine befor i had the "off duty" problem with other server. Could it be a cluster issue? I think i read somewhere that if you use two servers with the same license, on the same network, using a cluster license, the two will try to create a cluster (of sorts). The license that we have have 2 clusters nodes (but we are only using one server)

Employee
Employee

Re: Ajax client hangs, IE and open in server works.

Hi,

You can't use the same license on two separated, unless they are cluster. You can use a cluster license on a single server. When QVS starts up it will look to see if another QVS is using the license it has. If it finds a machine that is using its license it will go off duty.

Bill

Community Browser