Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

eliran_s
Contributor II

Can't assign cals in document

Hi all,

After upgrading qv server (11 sr2) I'm facing a weird problem with one of the documents.

I'm missing the 'Number of CALs allocated to this Document' field, therefore I can't assign any new cals to this document.

I have tried removing the document files (Metadata, Shared, qvw), but nothing helps.

In the summary I see the document got one embedded doc cal in it, but I don't know if it's related nor do I know how to remove it.

Any help?

This is how it looks..

Summary

Document CALs available on server

200
Document CALs not allocated on server135
Document CALs allocated to this document0
Document CALs embedded in document1
Document CALs assigned to users:0

Regards,

Eliran.

5 Replies
deepakk
Valued Contributor III

Re: Can't assign cals in document

hi Eliran,

Try clearing the .pgo files. You will find it in

"C:\ProgramData\QlikTech\Qvs"

This will clear all the assigned cals and it will reset all user assigned to it.

NoteSmiley Tonguelease make sure you take a back up of the same.

Deepak

eliran_s
Contributor II

Re: Can't assign cals in document

Hi,

The problem is I have many more documents on the server.

Doing this will result in clearing all assignments I have done in the past.

Any other solution?

Eliran.

deepakk
Valued Contributor III

Re: Can't assign cals in document

hi Eliran,

Please view the below post.

http://community.qlik.com/message/196164#196164

This will help in converting the pgo files to XML. IN this way you can read the pgo files.

Assigment of cals are stored in pgo files hence once you read the files, you might be in position to understand wats the issue is all about.

Regards

Deepak

eliran_s
Contributor II

Re: Can't assign cals in document

Hi,

I'm just in the middle of trying the above method

I will repost later on.

Thanks,

Eliran.

eliran_s
Contributor II

Re: Can't assign cals in document

Well, I do see what I've seen before, the problem is the 'NoOfEmbeddedNamedCals' field.

In the problematic model the value is 1 (as for the others where it's 0), and I don't know how to change it.

Any help will be much appreciated,

Eliran.

Edit: For now I have renamed the document name and it works fine (settings are cleared for this document), still bugs me tough..

Community Browser