Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Can't install QVS 10 - .NET framework 3.5 SP1 or greater needs to be installed

I have Microsoft .NET Framework 4 Client Profile and Microsoft .NET Framework 4 Extended installed. Why can't I install QVS 10?

6 Replies
danielrozental
Honored Contributor II

Can't install QVS 10 - .NET framework 3.5 SP1 or greater needs to be installed

That happened to me too, just install .NET Framework 3.5 SP1 regardless what the message says.

amien
Valued Contributor

Can't install QVS 10 - .NET framework 3.5 SP1 or greater needs to be installed

why is this? i have installed Framework 4.0, but the message : 3.5 or greater keeps coming.

strange thing is that i have installed server with framework 4.0 and this message didnt appear

Not applicable

Can't install QVS 10 - .NET framework 3.5 SP1 or greater needs to be installed

The 3.5 version of the .Net framework is NOT included in the v4, they are independent and thus incompatible (it is the same between 1.0 and 2.0, but it's not the case between 2 and 3.5). QVS needs the 3.5 framework, so having the 4th one does not fulfill the requirement.

amien
Valued Contributor

Can't install QVS 10 - .NET framework 3.5 SP1 or greater needs to be installed

i understand now why i dont see 3.5 sp1 in installed software list.

i'm using windows 2008. that ships with 3.5 sp1 included, but you need to enable it. When enabled it will install, but not show in the list of installed software.

MVP
MVP

Can't install QVS 10 - .NET framework 3.5 SP1 or greater needs to be installed

That's right,

Elaborating a bit for those who need it, that means going to the Control Panel, Programs and Features, and on the left list, Enable Windows Features, Roles, and there you will have .NET 3.

But it does list on my installed programs (Windows Server 2008 SP2).

Regards.

Not applicable

Re: Can't install QVS 10 - .NET framework 3.5 SP1 or greater needs to be installed

This bit me too!

It actually installs QV10 SR2 with only .NET4 installed, but then all of the services terminate immediately.  The event log says it can't find libraries for .NET 3.5.0.0

You must also install NET 3.5.1, per the instructions posted previously.

Community Browser