Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Announcements

Breathe easy -- you now have more time to plan your next steps with Qlik!
QlikView 11.2 Extended Support is now valid through December 31, 2020. Click here for more information.

Not applicable

Can't login to .qvw on access point as admin

Hi,

I'm having an issue where I have user/passwords defined using Section Access.

When I open my .qvw in Qlikview, I can use my defined admin user name and password just fine, but when I login to the .qvw via the Access Point, it won't accept my user/pass.  What is odd is that if I use one of the user/pass combos for a defined user, I can login. 

Very odd behavior.  Any thoughts??  Thanks!

Labels (1)
4 Replies
Employee
Employee

Re: Can't login to .qvw on access point as admin

I would have to see the Section Access load to see what might be the issue. If another user/pw will work and yours will not, then something is wrong with that account. Also, when you login to accesspoint and open a document that has section access applied, everyone is an user even if you have them listed as an administrator.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.
Not applicable

Re: Can't login to .qvw on access point as admin

Hi BIll,

Here is my script:

SECTION Access;

LOAD * Inline [

ACCESS,                    USERID,                    PASSWORD,          HEALTHGOAL

ADMIN,                    ADMIN,                    ADMIN,

USER, COACH1, HEALTHY,                     YES

USER, COACH2,                    HEALTHY,           YES

];

SECTION Application;

So I'm trying to reduce the data on load if Coach1 or Coach2 login and Healthgoal = Yes, while still letting me log in as an admin and see all the data.

Perhaps your last sentence is what I need to fix--just list a user that is technically the "admin," but has no value for the data reduction field in the section access script.

Employee
Employee

Re: Can't login to .qvw on access point as admin

Hi,

Try putting a * in all the blank fields for the Admin User. Then try it.

Bill

Bill - Designated Support Engineer at Qlik
If a post helps to resolve your issue, please mark the appropriate replies as CORRECT.

Re: Can't login to .qvw on access point as admin

Hi,

    Make sure that the field name HEALTHGOAL is same in your data model.

     If the name of the field is not same then sure this will not allow you to login.

     Also one more thing you must have checked the Strict Exclusion under Opening Tab of Document Properties.

     Now when you check that, it will not allow you to login if the FieldName doesnt matches with your data model (Section Application Area)

Regards,

Kaushik Solanki

Community Browser