Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Cannot find Audit Log

Running QV Server 10 SR3

Turned on Audit logging via QVEMC | System | Setup | <server> | Logging ... clicked Apply

Using default logging folder : C:\ProgramData\QlikTech\QlikViewServer

Login in to AccessPoint

Open file

No Audit_* file anywhere on server.

How often does the QVServer Flush logs?

I quit/restarted server but still no Audit_<machine> file.

4 Replies
danielrozental
Honored Contributor II

Re: Cannot find Audit Log

Daniel, logs should be generated in the logged folder that's parametrized in the QEMC, please make sure it's still the default folder as it might have been changed.

Also, make sure you or someone logs into an application for the log to be generated.

Not applicable

Re: Cannot find Audit Log

Per original post ... I looked in the folder used for logging (other logs were there). I logged onto the AccessPoint and opened a file which should be an "Audit-able" action. No Audit_<machine>.log was created.

The above actions were done 12/17.

I checked the log folder today, 12/18, and didfind Audit_<machine>.log with yesterday's event.

Today I again logged into the AccessPoint and opened a file. The Audit_<machine>.log file does NOT contain a record of this action.

How often does QVServer flush its internal log to the log file?

danielrozental
Honored Contributor II

Re: Cannot find Audit Log

In QV10 I believe QV will flush every instruction, not sure if there is a setting or a change in QlikView 11 to handle that differentely.

Not applicable

Re: Cannot find Audit Log

I do not see "flush every instruction" behavior. I have opened multiple documents today, 12/18, and the only entry I see in the Audit-<machine>.log is an entry from 12/17.

Was there a behavior change in various versions of 10, e.g. a bug in certain versions of v10 where Auditing did not work properly?

Community Browser