Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Cannot load reports in iPad app

Hi,

I can browse to our access point in both Safari and the Qlikview app on the iPad and can see the list of published reports. In Safari I can browse to individual reports and open them. In the app when selecting any report, the page hangs and it does not open. No error, just looks like it's loading but never completes.

I'm running Qlikview 11.20.12018.0 SR3 64 bit edition.

Our iPads use Junos Pulse for VPN connectivity with Kerberos authentication running on the proxy servers.

Presumably the authentication and other settings are configured correctly as it works in Safari.

Does anyone have an idea of what I might be missing on the app side of things?

Many thanks

Tags (4)
1 Solution

Accepted Solutions
Employee
Employee

Re: Cannot load reports in iPad app

Hello Jack!

The current release of the iOS App (2.0) does not yet support Kerberos as an authentication method.

Kind Regards,

Sonja

Sonja Bauernfeind
Senior Technical Support Engineer and Knowledge Centered Support Gremlin
7 Replies
erikadvectas
Valued Contributor

Re: Cannot load reports in iPad app

Hi Jack,

Is it possible that you can try without the VPN on an iPad?

Regards,

Erik

Not applicable

Re: Cannot load reports in iPad app

Thanks for the reply Erik,

I did some more investigating and tried without the VPN connection. This was successful when NTLM authentication was enabled in the IIS but failed with Kerberos authentication only - leading me to suspect that kerberos authentication is not supported under Qlikview SR3.

Unfortunately our VPN stipulates kerberos authentication so I'm currently upgrading the server to SR6 in the hope that Kerberos support is included.

I'll perform more tests once this is finished and report back.

Please feel free to correct my assumptions if you know otherwise

Cheers

Jack

erikadvectas
Valued Contributor

Re: Re: Cannot load reports in iPad app

Hi!

Indeed it is possible, it is just that NTLM is set by default.

See attached document.

The behavior has not changed for SR6.

Regards,

Erik

Not applicable

Re: Re: Cannot load reports in iPad app

Thanks.

Upgrading to SR6 did not help. I can still only access reports in Safari through the VPN, not via the app.

We're using Windows IIS and I'm pretty sure the config is OK given that it all works in Safari on iPad.

It must be something to do with the authentication used by the app. I can connect to the access point and see the list of reports, just not open them.

Is there a webconfig file for the app which I'm not seeing? Or some way to look at it's authentication protocol?

Any advice appreciated (again)

erikadvectas
Valued Contributor

Re: Re: Cannot load reports in iPad app

Hi Jack,

Please try to use the app without the VPN. Could be that the app is not picking up the VPN connection. Upgrading to SR6 does not make a difference in terms of authentication.

Regards,

Erik

Employee
Employee

Re: Cannot load reports in iPad app

Hello Jack!

The current release of the iOS App (2.0) does not yet support Kerberos as an authentication method.

Kind Regards,

Sonja

Sonja Bauernfeind
Senior Technical Support Engineer and Knowledge Centered Support Gremlin
Not applicable

Re: Re: Cannot load reports in iPad app


Thanks Sonja - I'll keep an eye out for future releases.

Erik - many thanks for all of your help! Much appreciated.

Cheers

Jack