Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Cannot start the QlikView Web Server

Hi all,

I have installed QlikView 9 in Window 2008 Server (64 bits) . The IIS is used instead of the default QlikView web server. However, after changing the URL of the QVWS to "http://localhost/QvAjaxZfc/AccessPointSettings.aspx" in QEMC, the web server cannot be started. I tested the url "http://localhost/QvAjaxZfc/AccessPointSettings.aspx" in IE, it shows the following result:

<Root>POST request without contents, can't process!</Root>

The result seems fine. Then I check the IIS log, there are many 401 and 404 errors:

#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2010-11-15 07:25:45 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 0
2010-11-15 03:02:53 127.0.0.1 GET /QvAjaxZfc/htc/QvAjax.js - 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 401 2 5 0

Any advices to me? Many thanks!

Best regards,
Edwin

7 Replies
Not applicable

Cannot start the QlikView Web Server

Hello,
if you're using IIS you don't need the QlikView Webserver, stop it.
Regards

Not applicable

Cannot start the QlikView Web Server

Thanks for your reply!

Actually, the default web server is stopped an IIS is being used. However, in QEMC, the status of QVWS is "Disconnected" and the content cannot be loaded by accessing "http://localhost/qlikview/".

1. The QlikView web server is stopped

2. The URL of QVWS is changed to "http://localhost/QvAjaxZfc/AccessPointSettings.aspx"

3. The QVWS cannot be started

Not applicable

Cannot start the QlikView Web Server

Do you have selected the "Microsoft IIS Support" during QVS installation?
Check if you see QVS virtual folders in IIS management console and if IIS is running.

Not applicable

Cannot start the QlikView Web Server

Yes, the virtual folders are installed in IIS and the IIS is in running status.

1. The virtual folders are installed in IIS and the IIS is running.

2. Cannot load content

3. Access the ASPX in IE

Not applicable

Cannot start the QlikView Web Server

Have you looked in IIS logs and Events? Ex ASP.NET extensions not enabled, or insuficcient permissions to read the files?

-Alex

Not applicable

Cannot start the QlikView Web Server

1) Here is the IIS logs:

#Software: Microsoft Internet Information Services 7.0
#Version: 1.0
#Date: 2010-11-16 03:09:42
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken
2010-11-16 03:09:42 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 577
2010-11-16 03:09:58 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 0
2010-11-16 03:10:14 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 15
2010-11-16 03:10:30 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 0
2010-11-16 03:10:46 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 15
2010-11-16 03:11:02 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 0
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/ - 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 401 2 5 0
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/ - 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 401 1 2148074254 0
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/ - 80 HBAP\HBAP-CRDMQVAPPS1 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 200 0 0 15
2010-11-16 03:11:08 127.0.0.1 GET /QvAjaxZfc/htc/QvAjax.js - 80 HBAP\HBAP-CRDMQVAPPS1 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 200 0 0 15
2010-11-16 03:11:08 127.0.0.1 GET /QvAjaxZfc/htc/QvAjaxBaseMgr.js - 80 HBAP\HBAP-CRDMQVAPPS1 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 200 0 0 31
2010-11-16 03:11:08 127.0.0.1 GET /QvAjaxZfc/htc/QvAjaxScan.js - 80 HBAP\HBAP-CRDMQVAPPS1 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 200 0 0 15
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/QvAccessPoint.js - 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 401 2 5 0
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/QvAccessPoint.js - 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 401 1 2148074254 0
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/AccessPoint.css - 80 HBAP\HBAP-CRDMQVAPPS1 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 200 0 0 15
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/QvAccessPoint.js - 80 HBAP\HBAP-CRDMQVAPPS1 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 200 0 0 0
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/header_footer.js - 80 HBAP\HBAP-CRDMQVAPPS1 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 200 0 0 0
2010-11-16 03:11:08 127.0.0.1 GET /qlikview/AccessPoint.jpg - 80 HBAP\HBAP-CRDMQVAPPS1 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 200 0 0 15
2010-11-16 03:11:08 127.0.0.1 POST /QvAjaxZfc/AccessPoint.aspx mark=&platform=browser.MSIE%207.0 80 - 127.0.0.1 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+6.0;+WOW64;+SLCC1;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.30729;+.NET+CLR+3.5.21022) 404 6 0 0
2010-11-16 03:11:19 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 0
2010-11-16 03:11:35 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 15
2010-11-16 03:11:51 127.0.0.1 POST /QvAjaxZfc/AccessPointSettings.aspx - 80 - 127.0.0.1 - 404 6 0 0

2) I can't find any special in Windows Event Log during browsing "http://localhost/QlikView"

3) The ASP.NET extensions is enabled

4) The identity of the application pool in IIS has sufficient permissions to read the files under QlikView installation path

Any other things I can check? Many thanks.

Not applicable

Cannot start the QlikView Web Server

i am also facing same poblem ..

Please help ..

Community Browser