Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Change the port of QlikView Web Server 10 ?

Hi,

i'm trying to install QV Web Server on a server that has already a Apache on port 80.

I have the QEMC and want to change it there but it doesn't save my new port :

Communication
Port:

The port always comes back to 80 and i can't start the Web Server Service

IIS is stopped and here is a part of the log

18/05/2011 15:31:42.9638966          Information          register prefix: "https://+:443/scripts/"

18/05/2011 15:31:42.9951452          Warning          https error. Exception: System.Net.HttpListenerException: The process cannot access the file because it is being used by another process

   at System.Net.HttpListener.AddAll()

   at System.Net.HttpListener.Start()

   at QlikView.AccessPoint.HttpServiceComponent.CreateAndStartHttpListener()

18/05/2011 15:31:42.9951452          Information          register prefix: "http://+:80/scripts/"

18/05/2011 15:31:42.9951452          Information          register prefix: "http://+:4750/"

18/05/2011 15:31:42.9951452          Information          register prefix: "http://+:80/qvajaxzfc/"

18/05/2011 15:31:42.9951452          Information          register prefix: "http://+:80/qlikview/"

18/05/2011 15:31:42.9951452          Information          register prefix: "http://+:80/qvclients/"

18/05/2011 15:31:42.9951452          Information          register prefix: "http://+:80/qvdesktop/"

18/05/2011 15:31:42.9951452          Information          register prefix: "http://+:80/qvplugin/"

I think changing the config.xml is useless on V10 .. what can i do ?

thanks

Tags (1)
1 Solution

Accepted Solutions
danielrozental
Honored Contributor II

Change the port of QlikView Web Server 10 ?

To change the Webserver port

<Config>

  <DefaultUrl>http://_:8080/</DefaultUrl>

  <DefaultQvs>Local</DefaultQvs>

If what you need is for the webserver to handle HTTPS traffic then you should check with the QlikView Server Reference for steps on how to do that.

In the error you pasted something is already listening in the 443 port.

6 Replies
danielrozental
Honored Contributor II

Change the port of QlikView Web Server 10 ?

To change the Webserver port

<Config>

  <DefaultUrl>http://_:8080/</DefaultUrl>

  <DefaultQvs>Local</DefaultQvs>

If what you need is for the webserver to handle HTTPS traffic then you should check with the QlikView Server Reference for steps on how to do that.

In the error you pasted something is already listening in the 443 port.

Not applicable

Change the port of QlikView Web Server 10 ?

Ok thanks

I have removed the 443 used by Apache

and even stopped apache .. then here is what i get :

18/05/2011 18:19:36.4188356          Information          register prefix: "https://+:443/scripts/"

18/05/2011 18:19:36.4344599          Warning          https error. Exception: System.Net.HttpListenerException: The tracking (workstation) service is not running

   at System.Net.HttpListener.AddAll()

   at System.Net.HttpListener.Start()

   at QlikView.AccessPoint.HttpServiceComponent.CreateAndStartHttpListener()

18/05/2011 18:19:36.4344599          Information          register prefix: "http://+:666/scripts/"

18/05/2011 18:19:36.4344599          Information          register prefix: "http://+:4750/"

18/05/2011 18:19:36.4344599          Information          register prefix: "http://+:666/qvajaxzfc/"

18/05/2011 18:19:36.4344599          Information          register prefix: "http://+:666/qlikview/"

18/05/2011 18:19:36.4344599          Information          register prefix: "http://+:666/qvclients/"

18/05/2011 18:19:36.4344599          Information          register prefix: "http://+:666/qvdesktop/"

18/05/2011 18:19:36.4344599          Information          register prefix: "http://+:666/qvplugin/"

18/05/2011 18:19:36.4344599          Error          System.Net.HttpListenerException: Failed to listen on prefix 'http://+:666/qvplugin/' because it conflicts with an existing registration on the machine.

   at System.Net.HttpListener.AddAll()

   at System.Net.HttpListener.Start()

   at QlikView.AccessPoint.HttpServiceComponent.CreateAndStartHttpListener()

   at QlikView.AccessPoint.HttpServiceComponent.Init(String[] args)

   at QlikView.AccessPoint.HttpServiceComponent.Start(String[] args)

Hmmm what's happening ?

Thanks

Not applicable

Change the port of QlikView Web Server 10 ?

Hi,

What's the file I have to change it?

tks

Change the port of QlikView Web Server 10 ?

Hi,

If you have windows 2003 you will find the file in the below location

C:\Documents and Settings\All Users\Application Data\QlikTech\WebServer

change the entries in config.xml file located in this folder

If you have windows 2008 you will find the file in the below location

C:\ProgramData\QlikTech\WebServer

change the entries in config.xml file located in this folder.

Hope it helps

Regards

ASHFAQ

Not applicable

Change the port of QlikView Web Server 10 ?

hmmm... On my installation I don't have the path \QlikTech\WebServer. Neither as hides.

But I found \QlikView\Web\

And in this folder the file 'web.config' with the lines:

<?xml version="1.0" encoding="UTF-8"?>

<configuration>

</configuration>

I tried this:

<?xml version="1.0" encoding="UTF-8"?>

<configuration>

  <DefaultUrl>http://_:8084/</DefaultUrl>

</configuration>

But didn't work...

Not applicable

Change the port of QlikView Web Server 10 ?

Great... I found it.

 

I was looking for wrong path...

 

Once the server is started, we can change the port at

http://localhost:4780/qemc/SystemSetup.htm#

 

System > Setup > QlikView WebServer > General

 

Tks

Community Browser