Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Changing webserver port value is not applied

Hello,

We Installed 'QlikViewServer_Win2012andUp' on 'Windows Server 2012', since we already have an Apache running on Port 80 on the same server, we changed the port value in the QMC (Qlikview Management Console) . After changing the value from 80 to 8181/81 etc., and press Apply, it shows as applying  with no error message,  But actually it doesnt updates the value and Opening the console again  it shows the same value 80. Is this a bug or something more needs to be done !

Thanks,

IMC

Labels (1)
1 Solution

Accepted Solutions

Re: Changing webserver port value is not applied

Workaround:

  • Shut down the QVWS service
  • Open C:\ProgramData\QlikTech\WebServer\config.xml
  • Change the <DefaultUrl> item so that it includes port 8181. The default is <DefaultUrl>http:/ /_/</DefaultUrl> which becomes <DefaultUrl>http:/ /_:8181/</DefaultUrl>
  • Start the QVWS service.

Best,

Peter

Ps Omit the space between http:/ and the next /. Done to avoid moderation.

6 Replies
gno
Valued Contributor II

Re: Changing webserver port value is not applied

Dear Peter,

I know apache uses from 80, 8080, 8811, but not sure about 8181. Check the QMC logs, see if there any error trying to change the ports.

Gio

Not applicable

Re: Changing webserver port value is not applied

Thanks, But Irrespective of the Port number set for the communication port, its not getting saved. whereas i could change the value of Location - URL which is saved.

Re: Changing webserver port value is not applied

Workaround:

  • Shut down the QVWS service
  • Open C:\ProgramData\QlikTech\WebServer\config.xml
  • Change the <DefaultUrl> item so that it includes port 8181. The default is <DefaultUrl>http:/ /_/</DefaultUrl> which becomes <DefaultUrl>http:/ /_:8181/</DefaultUrl>
  • Start the QVWS service.

Best,

Peter

Ps Omit the space between http:/ and the next /. Done to avoid moderation.

Employee
Employee

Re: Changing webserver port value is not applied

Hi,

You didn't say if you are using QVWS or IIS. It would appear you are using IIS if changing the port in the QMC doesn't work. That is only for QVWS.

If you are running IIS you will have to do that under bindings.

Bill

Not applicable

Re: Changing webserver port value is not applied

Thanks All, I was using the QVWS and the suggestion from Peter pcammaert worked out. Now the server is running, moving ahead with further configurations.

Regards!

Not applicable

Re: Changing webserver port value is not applied

Hi All,

I am trying to enable CORS on my QVWS, but nothing seems to be working, as I read on CORS website, just I need to enable by entering below details in web.config.

<configuration>
<system.webServer>
 
<httpProtocol>
  
<customHeaders>
  
<add name="Access-Control-Allow-Origin" value="*" />
  
<add name="Access-Control-Allow-Methods" value="GET,PUT,POST,DELETE,OPTIONS" />
  
<add name="Access-Control-Allow-Headers" value="Content-Type" />
  
</customHeaders>
 
</httpProtocol>
</system.webServer>
</configuration>


As I am trying Qlikview workbench DIV integration with Java web application.

Is anyone did like this or is anyone any thoughts, please share.


Thanks,