Qlik Community

QlikView Deployment

Discussion Board for collaboration related to QlikView Deployment.

Not applicable

Compression of QlikView Server slows down download time

I wrote extensions for QlikView and I noticed that my scripts take a lot more time to download then the QvAjax.js script. Firstly I thought it is because I generate my Javascript Code from Dart which makes the file size bigger and maybe the parse time longer.

But I found out, that it is another Problem: the compression of the files.

With the Chrome Web App ModHeader I disable the compression on the client by setting the “accept-encoding” header with an empty value.

ModHeader.PNG.png

The Files download faster, most of the time the client is just waiting for the response of the server.

WithCompressionHeader.PNG.png

Without the empty “accept-encoding” header, the compression slows down the download time:

WithoutCompressionHeader.PNG.png

With WLAN and disabled compression, the download isn’t that much slower than with LAN:

WlanWithCompressionHeader.PNG.png

But with enabled compression the whole site takes about ten times more time to download:

WlanWithoutCompressionHeader.PNG.png

I noticed that the images are not affected by this, but you can see in the table, that the images have the same size with compression enabled and without. Here the compression is disabled by default.

But I also noticed that the download of the QvAjax.js file is faster while compression is active especially with WLAN. With 868 KB, it is the file with the biggest size. With WLAN the download of this file is much faster with enabled compression, because the file is compressed down to just 224 KB. In this case, the compression works as it should. My theory: The QvAjax.js file is a static file and the server knows, that this file will never change. The file is already compressed and the server serves the compressed file immediately. The XHR Messages are generated at runtime, so the compression is done for each request. The scriptfiles of the extensions could change and the server doesn’t care about caching the compressed file, so these files are also compressed for each request. But the compression takes time and it is faster to just disable it in these cases.

Now my Question is, how do I disable the compression by default? I already disabled it in the Management Console but even after restarting the server, the compression is still active.

CompressNetworkTraffic.PNG.png

Community Browser